Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#106 closed defect (invalid)

Reply appears correct from within TB but receiving message still has original sender

Reported by: duoxi@… Owned by: rene
Version: 0.5.6 Keywords:
Cc:

Description

I cannot, for the life of me, get virtual identities to behave correctly.

Here is what I do, maybe you can detect where I am going astray...

  1. When writing email, click in the address bar and change the email sender on the left side. Now it says "user.one@…" on the left, and "user.two@…" at the right, for example.
  1. Click send. The saved copy of the mail looks perfect. It shows "user.one@…" as the sender.
  1. However, at the receipients end, it shows "user.two@…" and replying sends the reply to that address.
  1. I would have expected that the receipient would see "user.one@…"

Please advise.

Attachments (2)

virtualidentity-3.debug (4.9 KB) - added by duoxi@… 12 years ago.
virtualidentity-3.2.debug (4.9 KB) - added by duoxi@… 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by duoxi@…

Attachment: virtualidentity-3.debug added

Changed 12 years ago by duoxi@…

Attachment: virtualidentity-3.2.debug added

comment:1 Changed 12 years ago by anonymous

I attached a debug trace. Note that I caused this message not to go out, in order to be able to copy the full sequence of events before the composition window is closed.

Had this mail gone out, it would have shown user.two@… as sender (sorry, please use the second attachment "virtualidentity-3.2.debug" as I mistakenly added the first one wrong).

comment:2 Changed 12 years ago by rene

Hi,

maybe this is a problem with your email server. Do you have an own email server?

If the message in the sent folder says it all right, it should be transferred to the MTA (of your provider?) in exactly the same way. He (the MTA, the SMTP-server), on the other side is able to change whatever he likes in your email headers and maybe not allows you to use another sender address except the one you are registered with. Have you tried it with another mail (SMTP) server?

Nice regards, Rene

comment:4 Changed 11 years ago by rene

Resolution: invalid
Status: newclosed

closing because there was no followup information, feel free to reopen if problem persists.

Note: See TracTickets for help on using tickets.