Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#11 closed defect (fixed)

Normal Identities appear as Virtual Ones / Email-Adresses broken

Reported by: rene Owned by: rene
Version: Keywords:
Cc:

Description

For example, say i had one normal default identity as "Joe Smith -ACCT1", and another non-default as "Jim Jones -ACCT2". Now, when sending, if I select "Jim Jones -ACCT2" as the identity with which to send, it turns it into a "virtual id", and thinks the entire email address is "Jim Jones". It doesn't recognize that this is an identity with an email address associated with it.

I'm using thunderbird 2.0.0.6 and virtual id 0.4.3 pre.

thanks, allie

Change History (9)

comment:1 Changed 12 years ago by rene

your right, seems like a bug. Stored Identities should be used and recognized as such ones. But its hard to debug this way, if you are interested to find the problem please send a email to me (just at absorb dot it) with the Debug-Output (see options dialog).

regards, Rene

comment:2 Changed 12 years ago by anonymous

Hi Rene,

Thanks for your reply. Here's the output i get when switching to another identity. The problem I described above is still happening.

Thanks, Allie

Thunderbird 2.0.0.6 (2007072817; Windows NT 5.1)

  • Diccionario español Argentina es-AR@… 1.0
  • Remember Mismatched Domains {c8961d25-7d90-4c7e-893b-400a5c882920} 1.4.3
  • Talkback talkback@… 2.0.0.6
  • Toggle Word Wrap {cafe3945-058e-47e3-87f8-75bc120b9638} 1.0
  • View Headers Toggle Button {CC181FFE-82BD-4c02-907F-4B79C4C404F2} 2.0.1
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.4.3pre

## v_identity: replace MsgComposeCloseWindow? ## v_identity: adapt GenericSendMessage? ## v_identity: NotifyComposeFieldsReady? ## vI_smartIdentity: msgComposeType = 0 ## vI_smartIdentity: cant get URI of former Message ## v_identity: NotifyComposeBodyReady? ## vI_msgIdentityClone: MsgIdentityPopup?.doCommand() ## v_identity: replace GenericSendMessage? (Virtual Identity activated) ## v_identity: VIdentity_GenericSendMessage ## vI_account: Stored virtualIdentity (name email "Alexander Shenkin" smtp smtp2) ## vI_account: Stored (doFcc true fccFolder mailbox://nobody@Local%20Folders/Sent fccFolderPickerMode 0) ## vI_account: New Account created virtual Id0 ## v_identity: StateListener? reports ComposeProcessDone? ## vI_account: Account virtual Id0 removed

comment:3 Changed 12 years ago by Jens Musleh

Version: 0.4.3pre

I have exactly the same problem:

I have setup "Musleh, Jens - C.H.I.P. GbR, Sindelfingen" as Sendername and if I choose this account from the list it is shown as Virtual ID. And mails are sent with "Musleh" only - even the mail address is missing. So I can't use Virtual Identity with that, because the server adds some strange address instead of my domain name.

I think it is related to the "," in the sendername, because all other accounts don't have such character.

So I removed all ",": It's not shown as virtual ID now and the sendername (Jens Musleh - C.H.I.P. GbR Sindelfingen <musleh@…>) is not broken anymore.

I hope that helps to find out the bug, because I prefer to have the comma in my sendername.

comment:4 Changed 12 years ago by allie

Jens,

I don't have any commas in my sendernames, but i still have the issues above. So, not sure if the comma is the real issue. Or perhaps our two issues are somewhat different?

allie

comment:5 Changed 12 years ago by rene

Hi,

I also thought the comma is the issue, but more than that, the problem is that I parse the Identity you type with a header-parser function, delivered from Thunderbird to extract email and name (see source:/trunk/chrome/content/v_identity/vI_msgIdentityClone.js@23#L222 and than source:/trunk/chrome/content/v_identity/v_identity.js@28#L62). After returning email and name I'll compare it with the ones from the stored Identity. Which usually works fine...

But in some special cases it wont work, cause the header-parser is not used if you enter your Identity in the account settings dialog. So, I also have to use a different way to compare your input/your selection with the stored Identity.

Thanks for showing me the way, there will be a solution before the next release (I'm currently busy, but give me a week ;) )

Rene

comment:6 Changed 12 years ago by rene

Resolution: fixed
Status: newclosed

Ok, changed the way the address field is parsed. This should help, please test it. Done in [30]

comment:7 Changed 12 years ago by allie

Resolution: fixed
Status: closedreopened

Hi Rene,

Sorry to re-open a ticket on you (let me know if i should be creating new tickets instead, but it's the same problem I had before).

I still seem to be having the same problem with 0.4.4 that I was having before. That is, I have three identities: jim jones -account 1 jim jones -account 2 jim jones <alias.address@…> -account 2

When I start a message from "jim jones -account 1" and switch to "jim jones -account 2", virtual identity thinks that this is a new virtual identity, and it changes "jim jones" to red letters. When I try to send, i get an error ("An error occurred while sending mail. The mail server responded: 5.7.1 <addressCol2#>... 5.1.7 address incomplete. Please verify that your email address is correct in your Mail preferences and try again."). I get the same problem when trying to switch from starting in account 2 back to account 1. I _don't_ get issues when switching to "jim jones <alias.address@…> -account 2".

I'm including debug info below which shows what happened when I tried to switch a message from starting in "account 2" and switched the identity to "account 1". Thanks again, Rene.

Best, Allie

Thunderbird 2.0.0.9 (2007103104; Windows NT 5.1)

  • Diccionario español Argentina es-AR@… 1.0
  • Remember Mismatched Domains {c8961d25-7d90-4c7e-893b-400a5c882920} 1.4.3
  • Talkback talkback@… 2.0.0.9
  • Toggle Word Wrap {cafe3945-058e-47e3-87f8-75bc120b9638} 1.0
  • View Headers Toggle Button {CC181FFE-82BD-4c02-907F-4B79C4C404F2} 2.0.1
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.4.4

## v_identity: replace MsgComposeCloseWindow? ## v_identity: adapt GenericSendMessage? ## v_identity: NotifyComposeFieldsReady? ## vI_smartIdentity: msgComposeType = 0 ## vI_smartIdentity: cant get URI of former Message ## vI_smartIdentity: can't get Message Header. ## vI_smartIdentity: (maybe you're opening a message stored as a file) ## vI_addressBook: no recipient_email? ## vI_smartIdentity: checked for Addressbook-Identities and found 0 address(es) ## v_identity: NotifyComposeBodyReady? ## vI_addressBook: awOnBlur 'addressCol2#1' ## vI_addressBook: no email found, not checked. ## vI_msgIdentityClone: MsgIdentityPopup?.doCommand() ## v_identity: getAddress: name '#1' email 'addressCol2' ## v_identity: replace GenericSendMessage? (Virtual Identity activated)

comment:8 Changed 12 years ago by rene

Resolution: fixed
Status: reopenedclosed

Hi,

was (hopefully finally) repaired in [53], first found in pre-release 0.4.5pre. So please test one of the pre-release Versions (check the download area) and reopen the ticket if it still doesn't work.

Regards, Rene

comment:9 Changed 10 years ago by anonymous

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

Note: See TracTickets for help on using tickets.