Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#124 closed enhancement (fixed)

VI incorrectly identifying received message if no "Received" header; hidden option to override?

Reported by: mozkeith2@… Owned by: rene
Version: 0.5.10 Keywords:
Cc:

Description

Hi there,

There appears to be a specific issue with message headers for a specific sender that is causing Virtual Identity to think that messages sent by this person are NOT actually "received" messages, but sent ones. As a result, if I have "use SmartDraft?" checked, it changes the From line to be the sender, rather than my own.

I will attach the complete set of headers from two emails: an old one, which does NOT reproduce this problem, and a new one, which does. (The sender recently changed user agents, and all headers are like the new one.)

This problem reproduces in both 0.5.9 and 0.5.10.

Attachments (4)

headers-working.txt (650 bytes) - added by mozkeith2@… 11 years ago.
Message headers that behave properly
headers-broken.txt (485 bytes) - added by mozkeith2@… 11 years ago.
Message headers that cause the problem
debug-working.txt (4.0 KB) - added by mozkeith2@… 11 years ago.
Debug window information when replying to message that behaves properly
debug-broken.txt (4.6 KB) - added by mozkeith2@… 11 years ago.
Debug window information when replying to message with the problem

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by mozkeith2@…

Attachment: headers-working.txt added

Message headers that behave properly

Changed 11 years ago by mozkeith2@…

Attachment: headers-broken.txt added

Message headers that cause the problem

Changed 11 years ago by mozkeith2@…

Attachment: debug-working.txt added

Debug window information when replying to message that behaves properly

Changed 11 years ago by mozkeith2@…

Attachment: debug-broken.txt added

Debug window information when replying to message with the problem

comment:1 Changed 11 years ago by mozkeith2@…

I can summarize the problem much more succinctly now, after reviewing the debug logs.

In order for a message to be deemed "received", it looks like it needs to have a "Received:" header. This particular User Agent (Oracle Beehive Integration for Outlook) is not including a Received header, so VI misidentifies it.

Now, as it happens, it's my company that makes that user agent. If the IMAP standard states that the Received header is MANDATORY, I'll make them fix it, as it shouldn't be up to you to workaround buggy user agents, especially ones that have a very limited audience. But if that's not the case, a workaround setting would be nice to have.

comment:2 Changed 11 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

RFC 2821 (http://www.ietf.org/rfc/rfc2821.txt) says:

"4.4 Trace Information

When an SMTP server receives a message for delivery or further processing, it MUST insert trace ("time stamp" or "Received") information at the beginning of the message content, as discussed in section 4.1.1.4.

"

so, it's somehow on you to fix it. :) But I think I might add a (probably hidden) option to deactivate the header dependency in a next release. So I keep the ticket open to remember myself

Nice regards, Rene

comment:3 Changed 11 years ago by anonymous

Type: defectenhancement

Great! I've passed that info along. I'm sure it will help.

Thanks, Rene!

comment:4 Changed 11 years ago by anonymous

Summary: VI incorrectly identifying received message as non-received; setting sender incorrectly w/ SmartDraftVI incorrectly identifying received message if no "Received" header; hidden option to override?

comment:5 Changed 11 years ago by rene

Resolution: fixed
Status: assignedclosed

implemented with [487], part of preview 0.6.0pre1 (still alpha). Use pref-editor and change option smart_detectByReceivedHeader to false.

comment:6 Changed 11 years ago by anonymous

Thanks!

Just an update from the vendor: "...when you send a message using OBIO [Oracle Beehive Integration for Outlook], it's not delivered by smtp so rfc2821 doesn't necessarily apply. So it's a bit undefined whether the lack of the header is actually a problem."

They went on to say they may be changing it (which could take ages), but knowing there is this workaround in VI now, I can rest easier. Thanks Rene!

comment:7 Changed 10 years ago by anonymous

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

Note: See TracTickets for help on using tickets.