Opened 11 years ago

Closed 10 years ago

#132 closed defect (fixed)

Virtual Identity selects sender instead of recipient

Reported by: absorb.it@… Owned by: rene
Version: 0.5.11 Keywords:
Cc: absorb.it@…

Description

Hi,

virtual identity is the reason I am using Thunderbird - could not live without it (see my email for reason :-) ).

I have several identities in Thunderbird and in just one there are some emails where the sender gets selected as the virtual identity and not the recipient.

I checked the debug log (and will gladly send it to you in a non-public way) without any success (I don't see anything suspicious). In the yellow status it says

using Virtual Identity as sender. removed sender from recipients list.

Thanks a lot !!

Change History (15)

comment:1 Changed 11 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

nice to hear that the extension is helpful for you. Don't understand your bug-report, except that something is not working the way it should :) So please send the debug-log to me by email (to just at absorb dot it) - maybe we can figure out whats going wrong. Think of replacing confidential email-addresses before sending or posting it.

Nice regards, Rene

PS: I might be offline for a while in the next weeks, so don't be surprised if the reply takes a little longer.

comment:2 Changed 11 years ago by absorb.it@…

Version: 0.5.100.5.11

Hi,

after upgrading to 0.5.11 the issue remains unchanged.

Do you have any idea how to further debug this or what might be the problem?

Thanks a lot, Schlomo

comment:3 Changed 11 years ago by rene

Hi Schlomo,

didn't received any debug-log, maybe it was lost in some SPAM-eating filters between us? Still have no idea what the problem might be.

Nice regards, Rene

comment:5 Changed 10 years ago by rene

Resolution: invalid
Status: assignedclosed

no response, closing by now

comment:6 Changed 10 years ago by absorb.it@…

Resolution: invalid
Status: closedreopened

Rene,

I asked you in the beginning to tell me how I could send you a log via some private means. I do not wish to put my logs here on the public forum. You never answered that either.

Can we please go back to that, the issue is still unresolved. Or can we simply talk normally through email?

Thanks, Schlomo

comment:7 Changed 10 years ago by anonymous

I can confirm this error, but it only happens when you attempt to respond to an email without having opened it explicitly. One clicks simply on the email, then the reply-button, and the sender's name appears in the FROM field without a prompt.

However, this bug just mysteriously disappeared after I had opened the preview frame, hit the reply-button, then closed the preview frame and tried to reproduce the issue. The bug hasn't yet reappeared after restarting TB. I'll report if it returns again.

@Schlomo - try out the above steps and let us know if that solves the problem.

Underdog

comment:8 Changed 10 years ago by absorb.it@…

Hi,

I would second this observation. In my first tests I also did not open the email but replied from the preview pane (which is quite normal for me). In the later tests I always opened the mail to better grab the virtualid logs.

Schlomo

comment:9 Changed 10 years ago by tb@…

Hello,

I am also experiencing this problem, however it only seems to affect certain email, and I have not been able to determine any pattern. I however only noticed any problem at all after upgrading to Thunderbird 3_beta3.

I'm not sure what uesful information I can provide, so feel free to instruct me on what to collect and submit.

comment:10 Changed 10 years ago by absorb.it@…

Same problem here using TB 3.0 Beta 3

Clicking on 'Reply' in main window's toolbar

Thunderbird 3.0b3 (20090715140311; Windows NT 6.0)
 - Buttons! {a3ba6d6b-e8de-465a-b155-f87586e47039} 0.5.3.2
 - Enigmail [de] {847b3a00-7ab1-11d4-8f02-006008948af5} 0.95.7 [DISABLED]
 - Extra Folder Columns extra-cols@jminta_gmail.com 0.3
 - Folderpane Tools {b243fe83-b8a7-47de-855d-21d865243d5d} 0.0.5.1
 - Folderpane Tools [de] {D5682D27-B04B-44fd-A157-DC1C790FB65E} 0.0.5 [DISABLED]
 - Nightly Tester Tools {8620c15f-30dc-4dba-a131-7c5d20cf4a29} 2.0.2
 - openInTab openInTab@lds.ge 1.1
 - Remove Duplicate Messages (Alternate) {a300a000-5e21-4ee0-a115-9ec8f4eaa92b} 0.3.2
 - Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.5.11
--------------------------------------------------------------------------------
## v_identity: composeDialog reopened. (msgType 6)
## v_smtpSelector: clean
## vI_msgIdentityClone: cleanReplyToFields
## v_identity: everything cleaned.
## v_identity: initSystemStage1.
## v_smtpSelector: __selectUsedSMTPServer
## v_smtpSelector: setMenuToKey 'smtp3'
## v_smtpSelector: use SMTP from BaseIdentity: smtp3
## vI_msgIdentityClone: 'id3'
## vI_msgIdentityClone: LoadIdentity
## vI_msgIdentityClone: cleanupReplyTo
## vI_msgIdentityClone: copySelectedIdentity
## vI_msgIdentityClone: copySelectedIdentity MsgIdentityPopup.doCommand()
## v_smtpSelector: setMenuToKey 'smtp3'
## vI_msgIdentityClone: initReplyToFields id=id3
## vI_msgIdentityClone: initReplyToFields identity.replyTo: 
## v_identity: getAddress: address 'MY NAME <defaultidentity@mydomain.net>' name 'MY NAME' email 'defaultidentity@mydomain.net'
## vI_storage: isExistingIdentity compare with Identity id3
## vI_storage: existing Identity found: id3
## v_identity: reopen done.
## v_identity: NotifyComposeFieldsReady
## v_identity: NotifyComposeBodyReady
## v_identity: initSystemStage2.
## vI_msgIdentityClone: initReplyToFields id=id3
## vI_msgIdentityClone: initReplyToFields identity.replyTo: 
## vI_smartIdentity: msgComposeType = 6
## vI_smartIdentity: Reply()
## vI_smartIdentity: reply on non-received (sent?) mail. Using SmartDraft. 
## vI_smartIdentity: ReplyOnSent() (rules like SmartDraft)
## vI_smartIdentity: __SmartDraftOrReplyOnSent()
## vI_smartIdentity: sender 'SENDER NAME <my@correspondent.net>'
## vI_storage: getVIdentityFromAllRecipients()
## vI_storage: isMailingList 'SENDER NAME <my@correspondent.net>' 
## vI_storage: isMailList  false.
## v_identity: getAddress: address 'SENDER NAME <my@correspondent.net>' name 'SENDER NAME' email 'my@correspondent.net'
## vI_rdfDatasource: readVIdentityFromRDF.
## vI_rdfDatasource: __getRDFResourceForVIdentity: recDescription=SENDER NAME <my@correspondent.net>
## vI_rdfDatasource: readVIdentityFromRDF found stored data.
## vI_rdfDatasource: email 'virtualid@mydomain.net'
## vI_rdfDatasource: fullName 'MY NAME'
## vI_rdfDatasource: id 'null'
## vI_rdfDatasource: smtp 'smtp3'
## vI_rdfDatasource: extras: 
## identityCollection:   add new address to result:MY NAME <virtualid@mydomain.net>
## vI_storage: found 1 address(es)
## identityCollection:   add new address to result:MY NAME <virtualid@mydomain.net>
## vI_msgIdentityClone: addIdentityToCloneMenu 'undefined'
## vI_storage: isExistingIdentity compare with all Identities
## vI_storage: none existing Identity found.
## vI_msgIdentityClone: addIdentityToCloneMenu existingId 'null'
## vI_msgIdentityClone: addSeparatorToCloneMenu
## vI_helper: addIdentityMenuItem 'virtuelle Id'
## vI_msgIdentityClone: addIdentityToCloneMenu 'null'
## vI_storage: isExistingIdentity compare with all Identities
## vI_storage: none existing Identity found.
## vI_msgIdentityClone: addIdentityToCloneMenu existingId 'null'
## vI_helper: addIdentityMenuItem 'virtuelle Id'
## vI_msgIdentityClone: setMenuToMenuItem 'virtuelle Id'
## vI_msgIdentityClone: setMenuToMenuItem MsgIdentityPopup_clone.doCommand()
## vI_msgIdentityClone: LoadIdentity
## vI_msgIdentityClone: LoadIdentity virtual Identity
## v_smtpSelector: setMenuToKey ''
## vI_msgIdentityClone: label: 'SENDER NAME <my@correspondent.net>'
## v_identity: getAddress: address 'SENDER NAME <my@correspondent.net>' name 'SENDER NAME' email 'my@correspondent.net'
## vI_storage: isExistingIdentity compare with Identity id3
## vI_storage: none existing Identity found.
** benutze eine Virtuelle Identität als Sender (mehr als eine Adresse gefunden).
## vI_storage: awSetInputAndPopupValue 'addressCol2#1'
## vI_storage: updateVIdentityFromStorage()
## vI_storage: no recipient found, not checked.
**  Sender aus Empfängerliste gelöscht.

Mail header (stripped Received-Header):

Received: (qmail 12164 invoked by uid 110); 18 Aug 2009 13:59:31 +0200
Delivered-To: 1-virtualid@mydomain.net
Received: (qmail 12159 invoked from network); 18 Aug 2009 13:59:31 +0200
Received: from ***
  by *** with SMTP; 18 Aug 2009 13:59:31 +0200
Received-SPF: none (***: domain at web.de does not designate permitted sender hosts)
X-Greylist: whitelisted by controllist (id = 13)
Received: from *** 
	by *** (Postfix) with SMTP id C2F6F5C538FB
	for <virtualid@mydomain.net>; Tue, 18 Aug 2009 13:59:30 +0200 (CEST)
Received: from [***.***.***.***] by *** with HTTP;
 Tue, 18 Aug 2009 13:59:29 +0200
Date: Tue, 18 Aug 2009 13:59:29 +0200
Message-Id: <1908005680@web.de>
MIME-Version: 1.0
From: SENDER NAME <my@correspondent.net>
To: MY NAME <virtualid@mydomain.net>
Subject: Re: Some subject
Precedence: fm-user
Organization: ***
X-Provags-Id: V01U2FsdGVkX18RwkE+D2JEeFqmDC3LOktTXGp9HK4Ms3QnnO5A8U/GlPYIL
 jcLpCuKgJBMiYfxEQz2MawY4Vr0fbGLa5ftUVpxR7FCYxGwDmb7gsU79JLLh
 A==
Content-Type: text/plain; charset=iso-8859-15
Content-Transfer-Encoding: quoted-printable

So, the mail was

From: SENDER NAME <my@…> To: MY NAME <virtualid@…>

but VI selected

SENDER NAME <my@…>

instead of

MY NAME <virtualid@…>

as the virtual identity for my new reply, wiping out the receipient list.

comment:11 Changed 10 years ago by rene

Resolution: duplicate
Status: reopenedclosed

Check the debugging output, seems like your received emails doesn't contain any 'received' headers. There is a related switch in 0.6.0pre2, please try (if you like this beta) and report if this works for you.

More about the same problem can be found in #131 (and #124).

Nice regards, Rene

comment:12 Changed 10 years ago by absorb.it@…

Resolution: duplicate
Status: closedreopened

If you could look again at the mail headers I posted above, there are 5 received-headers in the mail I want to reply to:

Received: (qmail 12164 invoked by uid 110); 18 Aug 2009 13:59:31 +0200
Received: (qmail 12159 invoked from network); 18 Aug 2009 13:59:31 +0200
Received: from ***
  by *** with SMTP; 18 Aug 2009 13:59:31 +0200
Received: from *** 
	by *** (Postfix) with SMTP id C2F6F5C538FB
	for <virtualid@mydomain.net>; Tue, 18 Aug 2009 13:59:30 +0200 (CEST)
Received: from [***.***.***.***] by *** with HTTP;
 Tue, 18 Aug 2009 13:59:29 +0200

comment:13 Changed 10 years ago by rene

Hi,

yeah, just looked to short on the details :) Seems like it does not detect the headers, think the problem is an imcompatibility with Thunderbird 3.0b3. Check #145 . Can you check the Javascript Error Console (see Tools Menu) for any Error Messages?

Thanks, Rene

PS: Can't download TB 3.0b3 now, no broadband available. So can't test it locally.

comment:14 Changed 10 years ago by absorb.it@…

The Error Console shows nothing when the detection fails. I'll try if the current beta version 0.6.0pre2 already fixes that bug.

comment:15 Changed 10 years ago by rene

Hi,

if you enable the debug-output, you should be able to see something like "found header: received ...stored to recognize received mail" in the log. Is there something like this?

Regards, Rene

comment:16 Changed 10 years ago by absorb.it@…

Resolution: fixed
Status: reopenedclosed

Nevermind, version 0.6.0pre2 fixes this issue. Thanks!

Note: See TracTickets for help on using tickets.