Opened 10 years ago

Closed 10 years ago

#148 closed defect (wontfix)

S/MIME and PGP settings are not used from the virtual identity

Reported by: Alois Hockenschlohe Owned by:
Version: 0.5.11 Keywords: PGP S/MIME
Cc:

Description

Version: 0.5.11

Settings: UNCHECKED: Virtual Identity -> attributes to copy -> S/MIME Security Settings ALL CHECKED: Storage -> Additional options -> S/MIME ALL CHECKED: Storage -> Additional options -> OpenPGP

In the Virtual Identity Data Storage, the recipient ist stored with the following settings:

Thunderbird 2.0.0.23 (2009081714; Linux i686)

  • Deutsches Wörterbuch de-DE@… 1.0.1
  • Enigmail {847b3a00-7ab1-11d4-8f02-006008948af5} 0.95.0
  • Quicktext {8845e3b3-e8fb-40e2-95e9-ec40294818c4} 0.9.9.9
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.5.11

## v_smtpSelector: setMenuToKey 'smtp1' ## vI_storageExtras setEditorValue reciept=null ## vI_storageExtras setEditorValue charEnc=null ## vI_storageExtras setEditorValue msgFormat=null ## vI_storageExtras setEditorValue sMimeEnc=true ## vI_storageExtras setEditorValue sMimeSig=true ## vI_storageExtras setEditorValue PGPEnc=false ## vI_storageExtras setEditorValue PGPSig=false ## vI_storageExtras setEditorValue PGPMIME=false

If the user is given as a recipient inside the Compose window from Thunderbird, the following debug output appears:

## vI_storage: awOnBlur 'addressCol2#1' ## vI_storage: updateVIdentityFromStorage() ## vI_storage: isMailingList 'xxxx <xxx@xxxxxxxxxxx>' ## vI_storage: isMailList false. ## v_identity: getAddress: address 'xxxx <xxx@xxxxxxxxxxx>' name 'xxxx' email 'xxx@xxxxxxxxxxxxxxxx' ## vI_rdfDatasource: readVIdentityFromRDF. ## vI_rdfDatasource: getRDFResourceForVIdentity: recDescription=xxxx <xxx@xxxxxxxxxxx> ## vI_rdfDatasource: readVIdentityFromRDF found stored data. ## vI_rdfDatasource: email 'xxx@xxxxx' ## vI_rdfDatasource: fullName 'xxxxxxxxxxxxx' ## vI_rdfDatasource: id 'id1' ## vI_rdfDatasource: smtp 'smtp1' ## vI_rdfDatasource: extras: sMimeEnc='true' sMimeSig='true' PGPEnc='false' PGPSig='false' PGPMIME='false' ## vI_storage: compare with current Identity ## v_identity: getAddress: address 'xxxx@xxxxxxxxxx' name 'xxxxxxxxxx' email 'xxx@xxxxxxxxxxxxxx' ## vI_storageExtras readValue reciept=null ## vI_storageExtras readValue charEnc=null ## vI_storageExtras readValue msgFormat=null ## vI_storageExtras readValue sMimeEnc=false ## vI_storageExtras readValue sMimeSig=true ## vI_storageExtras readValue PGPEnc=true ## vI_storageExtras readValue PGPSig=true ## vI_storageExtras readValue PGPMIME=false ## vI_storageExtras equal true : false ## vI_storageExtras equal true : true ## vI_storageExtras equal false : true ## vI_storageExtras equal false : true ## vI_storageExtras equal false : false ## vI_storageExtras getCompareMatrix <tr><td class='col1 extras unequal'>S/MIME encrypt</td><td class='col2 extras unequal'><div class='bool'><label class='screen'>&nbsp;<label><label class='braille'>no</label></div></td><td class='col3 extras unequal'><div class='bool checked'><label class='screen'>&nbsp;<label><label class='braille'>yes</label></div></td></tr><tr><td class='col1 extras equal'>S/MIME sign</td><td class='col2 extras equal'><div class='bool checked'><label class='screen'>&nbsp;<label><label class='braille'>yes</label></div></td><td class='col3 extras equal'><div class='bool checked'><label class='screen'>&nbsp;<label><label class='braille'>yes</label></div></td></tr><tr><td class='col1 extras unequal'>openPGP encrypt</td><td class='col2 extras unequal'><div class='bool checked'><label class='screen'>&nbsp;<label><label class='braille'>yes</label></div></td><td class='col3 extras unequal'><div class='bool'><label class='screen'>&nbsp;<label><label class='braille'>no</label></div></td></tr><tr><td class='col1 extras unequal'>openPGP sign</td><td class='col2 extras unequal'><div class='bool checked'><label class='screen'>&nbsp;<label><label class='braille'>yes</label></div></td><td class='col3 extras unequal'><div class='bool'><label class='screen'>&nbsp;<label><label class='braille'>no</label></div></td></tr><tr><td class='col1 extras equal'>openPGP PGP/MIME</td><td class='col2 extras equal'><div class='bool'><label class='screen'>&nbsp;<label><label class='braille'>no</label></div></td><td class='col3 extras equal'><div class='bool'><label class='screen'>&nbsp;<label><label class='braille'>no</label></div></td></tr> ## vI_msgIdentityClone: addIdentityToCloneMenu 'id1' ## vI_storage: isExistingIdentity compare with Identity id1 ## vI_storage: existing Identity found: id1 ## vI_msgIdentityClone: addIdentityToCloneMenu existingId 'id1' ## vI_msgIdentityClone: setMenuToMenuItem ' - mail' ## vI_msgIdentityClone: setMenuToMenuItem MsgIdentityPopup_clone.doCommand() ## vI_msgIdentityClone: LoadIdentity? ## vI_msgIdentityClone: cleanupReplyTo ## vI_msgIdentityClone: copySelectedIdentity ## vI_msgIdentityClone: copySelectedIdentity MsgIdentityPopup?.doCommand() ## v_smtpSelector: setMenuToKey 'smtp1' ## vI_msgIdentityClone: initReplyToFields id=id1 ## vI_msgIdentityClone: initReplyToFields identity.replyTo: ## v_identity: getAddress: address 'xxxxxx <xxx@xxxxxxxx>' name 'xxxxxx' email 'xxx@xxxxxxxx' ## vI_storage: isExistingIdentity compare with Identity id1 ## vI_storage: existing Identity found: id1 ## vI_storage: awOnBlur 'addressCol2#2' ## vI_storage: updateVIdentityFromStorage() ## vI_storage: no recipient found, not checked.

But the Encryption won't change from "PGP: Encrypt and Sign, S/MIME: Sign" to "PGP: do not encrypt and do not sign, S/MIME: Encrypt and Sign".

But maybe, I'm just too dump...?

Change History (3)

comment:1 Changed 10 years ago by S/MIME and thunderbird...

Version: 0.5.11

Same behaviour. PGP and S/MIME settings do not work. But the documentation of Virtual Identity is not in a usable state, so maybe I'm also just configured some settings the wrong way?!

comment:2 Changed 10 years ago by Alois Hockenschlohe

It works perfect with 0.6.0pre2. :-)

comment:3 Changed 10 years ago by rene

Resolution: wontfix
Status: newclosed

Hi Alois,

thanks for the detailed report. If the settings are working with 0.6.0pre2, I won't take too much time to unvestigate the problem with the current 0.5.11 . Currently without a usable broadband, it's hard for me to check all different use-cases on my own. If you see some related error messages in the javascript console (see tools menu) than I might catch the problem, else you have to wait for 0.6.0.

Nice regards, Rene

PS: closed the ticket, please reopen if you find an error-message or something alike.

Note: See TracTickets for help on using tickets.