Opened 10 years ago

Closed 10 years ago

#155 closed defect (wontfix)

GenericSendMessage not replaced -> virt. Identity not active

Reported by: 244la3adzj6dm4z@… Owned by:
Version: Keywords:
Cc:

Description

I just forwarded an email, changing the smtp server from gmail to the one from my university, also changing the "from" email, and it passed trough gmail (so it's a bug).

If, however, I change to using an other account (which as an other SMTP server associated with, it works fine)

thanks and continue the good job

Change History (9)

comment:1 Changed 10 years ago by rene

Resolution: invalid
Status: newclosed

Hi,

it's probably a problem with gmail. See #32 .

Regards, Rene

comment:2 Changed 10 years ago by 244la3adzj6dm4z@…

Resolution: invalid
Status: closedreopened

Hum I think you should re-open this bug. I selected my university SMTP server, and it still went trought gmail. This has nothing to do with bug #32. I know that gmail has a frustrating behavior and that's why I selected an other SMTP server, which works well by the way when I send an email using the accound associated with.

comment:3 Changed 10 years ago by rene

Hi, right, now I understand what the problem is. Can you please provide information about the used version and the used platform and other extensions? (check debug-output for relevant information, can be enabled in the config dialog)

Thanks and nice regards, Rene

comment:4 Changed 10 years ago by 244la3adzj6dm4z@…

Sure here it is : It seems that manually choosing the SMTP server doesn't always work. I rely on this feature a lot and never found that bug before a few days ago. I upgraded from 0.5.11 to 0.5.12 but it didn't solve my problem.

Mozilla-Thunderbird 2.0.0.22 (2009070714; Linux x86_64)

  • Canadian English Dictionary en-CA@… 1.1.4
  • Diccionario de Español/España? es-es@… 1.2.1
  • Enigmail {847b3a00-7ab1-11d4-8f02-006008948af5} 0.95.0 [DISABLED]
  • GMailUI {03EF8A6E-C972-488f-92FA-98ABC2C9F8B9} 0.6 [DISABLED]
  • Installation des boutons d'Antidote antidote7_linux_thunderbird_103@… 7.0.0909261400
  • New Mail Icon {2e1b75f1-6b5a-4f1d-89b4-424f636e4fba} 1.2.3
  • Spamato4Thunderbird {73111b5c-ee6e-4e1e-b4f2-df2cbb79ede5} 0.99.9
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.5.12

## v_identity: composeDialog reopened. (msgType 6) ## v_smtpSelector: clean ## vI_msgIdentityClone: cleanReplyToFields ## v_identity: everything cleaned. ## v_identity: initSystemStage1. ## v_smtpSelector: selectUsedSMTPServer ## v_smtpSelector: setMenuToKey 'smtp3' ## v_smtpSelector: use SMTP from BaseIdentity?: smtp3 ## vI_msgIdentityClone: 'id3' ## vI_msgIdentityClone: LoadIdentity? ## vI_msgIdentityClone: cleanupReplyTo ## vI_msgIdentityClone: copySelectedIdentity ## vI_msgIdentityClone: copySelectedIdentity MsgIdentityPopup?.doCommand() ## v_smtpSelector: setMenuToKey 'smtp3' ## vI_msgIdentityClone: initReplyToFields id=id3 ## vI_msgIdentityClone: initReplyToFields identity.replyTo: ## v_identity: getAddress: address 'Foo Bar <foobar@…>' name 'Foo Bar' email 'foobar@…' ## vI_storage: isExistingIdentity compare with Identity id3 ## vI_storage: existing Identity found: id3 ## v_identity: reopen done. ## v_identity: NotifyComposeFieldsReady? ## v_identity: NotifyComposeBodyReady? ## v_identity: initSystemStage2. ## vI_msgIdentityClone: initReplyToFields id=id3 ## vI_msgIdentityClone: initReplyToFields identity.replyTo: ## vI_smartIdentity: msgComposeType = 6 ## vI_smartIdentity: Reply() ## vI_storage: getVIdentityFromAllRecipients() ## vI_storage: isMailingList 'Michel Somefriend <friend@…>' ## vI_storage: isMailList false. ## v_identity: getAddress: address 'Michel Somefriend <friend@…>' name 'Michel Somefriend' email 'friend@…' ## vI_rdfDatasource: readVIdentityFromRDF. ## vI_rdfDatasource: getRDFResourceForVIdentity: recDescription=Michel Somefriend <friend@…> ## vI_rdfDatasource: readVIdentityFromRDF found stored data. ## vI_rdfDatasource: email 'foo@…' ## vI_rdfDatasource: fullName 'Foo Bar' ## vI_rdfDatasource: id 'null' ## vI_rdfDatasource: smtp 'smtp6' ## vI_rdfDatasource: extras: ## identityCollection: add new address to result:Foo Bar <foo@…> ## vI_storage: found 1 address(es) ## vI_smartIdentity: SmartReply? skipped, Identities in Storage found. ## vI_smartIdentity: merged SmartReply? & Storage, 1 address(es) left ## vI_msgIdentityClone: addIdentityToCloneMenu 'null' ## vI_storage: isExistingIdentity compare with all Identities ## vI_storage: none existing Identity found. ## vI_msgIdentityClone: addIdentityToCloneMenu existingId 'null' ## vI_msgIdentityClone: addSeparatorToCloneMenu ## vI_helper: addIdentityMenuItem 'Id virtuelle' ## vI_msgIdentityClone: setMenuToMenuItem 'Id virtuelle' ## vI_msgIdentityClone: setMenuToMenuItem MsgIdentityPopup_clone.doCommand() ## vI_msgIdentityClone: LoadIdentity? ## vI_msgIdentityClone: LoadIdentity? virtual Identity ## v_smtpSelector: setMenuToKey 'smtp6' ## vI_storageExtras setValue reciept=null ## vI_storageExtras setValue charEnc=null ## vI_storageExtras setValue msgFormat=null ## vI_storageExtras setValue sMimeEnc=null ## vI_storageExtras setValue sMimeSig=null ## vI_storageExtras setValue PGPEnc=null ## vI_storageExtras setValue PGPSig=null ## vI_storageExtras setValue PGPMIME=null ## vI_msgIdentityClone: label: 'Foo Bar <foo@…>' ## v_identity: getAddress: address 'Foo Bar <foo@…>' name 'Foo Bar' email 'foo@…' ## vI_storage: isExistingIdentity compare with Identity id3 ## vI_storage: none existing Identity found. Utilisation de l'identité virtuelle comme expéditeur. ## vI_msgIdentityClone: inputEvent. ## v_identity: getAddress: address 'Foo Bar <foo@…>' name 'Foo Bar' email 'foo@…' ## vI_storage: isExistingIdentity compare with Identity id3 ## vI_storage: none existing Identity found. ## vI_storage: awOnBlur 'addressCol2#1' ## vI_storage: updateVIdentityFromStorage() ## vI_storage: isMailingList 'testbobxav@…' ## vI_storage: isMailList false. ## v_identity: getAddress: address 'testbobxav@…' name email 'testbobxav@…' ## vI_rdfDatasource: readVIdentityFromRDF. ## vI_rdfDatasource: getRDFResourceForVIdentity: recDescription=testbobxav@… ## vI_rdfDatasource: readVIdentityFromRDF no data found. ## vI_storage: awOnBlur 'addressCol2#2' ## vI_storage: updateVIdentityFromStorage() ## vI_storage: no recipient found, not checked.

comment:5 Changed 10 years ago by rene

Hi,

can you reproduce the problem? Then please tempararily activate dumping of messages to the terminal. Open the "Thunderbird Preferences" dialog, Tab "Advanced" -> "General" and will find the config editor. Search for "dump" and change "browser.dom.window.dump.enabled" to true. Then start thunderbird from your terminal with Virtual Identity debug output enabled und post (or email) the output - this way we can catch the send phase too.

Else please check the Error Console (Tools Menu) for relevant messages.

Nice regards, Rene

comment:6 Changed 10 years ago by virtualidentity@…

Hi I made more tests and it seems that VI doesn't work at all for me (not just the SMTP server change, but also the "from" field editing). This is on my Debian laptop. I also tested on my windows box, with only 1 SMTP server, and changing the "from" field didn't work.

I made the dumps that you asked. First example is sending an email by changing the SMTP server and the from field. Second example is changing the from field only (this time smtp server isn't gmail by default). I am willing to help you on this as I rely heavily on VI for every day usage. I know it worked before... I don't know what happened.

Ok.. what I am trying to send is too long and is detected as spam. I will try an other way to send it.

comment:7 Changed 10 years ago by rene

Hi,

just saved and removed your attachement, some email addresses had not been hidden. I will try to see what's happening in your cases...

If you like to send further traces you can see my email address on the home-page of this trac.

Regards, Rene

comment:8 Changed 10 years ago by rene

Summary: changing SMTP server doesn't always workGenericSendMessage not replaced -> virt. Identity not active

Hi,

something going really wrong with your extension installation. Virtual Identity does not get active for whatever reason. The complete log should lok something like this...

## v_identity: mod. FillIdentityListPopup 
## v_identity: init.
## v_identity: adapt GenericSendMessage   
## v_identity: initSystemStage1. 
...
SendMessage from XUL     
## v_identity: VIdentity_GenericSendMessage 
## vI_storage: ----------------------------------------------------------        
...
## vI_account: Stored virtualIdentity (name rene for a test email rene@debain-mail smtp smtp1)
## vI_account: copy S/MIME settings
## vI_account: preparing Fcc --- use Virtual Identity Settings
## vI_account: Stored (doFcc true fccFolder imap://rene%40debian-mail@mail.debian-mail/Sent fccFolderPickerMode 0(0))
## vI_account: preparing Draft --- use Virtual Identity Settings
## vI_account: Stored (draftFolder mailbox://nobody@Local%20Folders/Drafts draftsFolderPickerMode 0(0))
## vI_account: preparing Templates --- use Virtual Identity Settings
## vI_account: Stored (stationeryFolder imap://rene%40debian-mail@mail.debian-mail/Templates tmplFolderPickerMode 0(0))
## vI_helper: addIdentityMenuItem ' - rene@debain-mail'
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id9]
DetermineHTMLAction: preferFormat = 0, noHtmlRecipients are test@debian-mail
## v_identity: StateListener reports ComposeProcessDone
## vI_account: removing account account9.
## vI_storage: clean.

The Beginning is right after opening a MessageCompose window (press new mail for the first time after Thunderbird start - second time is different). There should be a line containing "adapt GenericSendMessage". The generic SendMessage function has to be changed to let Virtual Identity work. If this is succesfully done, in the event of you pressing the Send Button an new SendMessage from XUL is called. This new one "VIdentity_GenericSendMessage" first creates an account "vI_account: Stored virtualIdentity..." This is not shown in your logs, you are still using the unmodified SendMessage.

No we have to search for the reason :) Right after opening the MessageCompose dialog, are there any errors in the error console? While sending, are there any errors? Have you tried it without any other extensions installed parallel?

Nice regards, Rene

comment:9 Changed 10 years ago by virtualidentity@…

Resolution: wontfix
Status: reopenedclosed

I found what is my problem... I have an other extension (Antidote) which is a spell checker. Now that I remember, it has a new function that checks spelling right before sending, but I wasn't using it. Now that I disabled Antidote, virtual identity works again. Sorry for all this... at least you might add this extension in your "not compatible with" list.

I guess this can't be fixed easily without cooperation with the maker of the other extension so I am marking this as wontfix.

thanks for your help

Note: See TracTickets for help on using tickets.