Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#158 closed defect (fixed)

Many TB crashes with 0.6.0pre4

Reported by: mozkeith2@… Owned by: rene
Version: 0.6.0pre4 Keywords:
Cc:

Description

Hi there,

I really despise the summary I have so far, but I need some guidance on what debugging information to provide.

I've been using 0.6.0pre4 for only about an hour. First, I'm happy to see the fix for enh #124 -- thank goodness, as this was driving me nuts.

However, the stability of pre4 was shaky enough that I have to rollback for regular use, as I experienced about a dozen crashes in that one hour time period, most of them clustered at the end.

The crashes do not ALWAYS occur, but when they do, it is either when I:

1) start to compose a new message (before the window pops up) 2) hit reply-all (in at least one of my mail accounts, haven't tried others yet) 3) hit send on a replied message, where the virtID and smtp have not been changed.

As you can see, there's very little commonality to where and how these crashes occur, so I need some guidance on what debugging information you'd like to see when these crashes do happen.

Once I know, I can modify the bug description and log separate bugs for each distinctly separate scenario where the crash is occuring.

Cheers, Keith

Change History (4)

comment:1 Changed 10 years ago by rene

Owner: set to rene
Status: newassigned

Hi Keith,

not nice to hear that this is a total disaster for you. I will see what I can do to get rid of the problem. First, which version of Thunderbird / Seamonkey are you using? Did any other 0.6 pre version worked with the same TB/SM version?

Thanks for the report, nice regards, Rene

comment:2 Changed 10 years ago by Keith S. <mozkeith2@…>

You're too polite, Rene. It's not a total disaster, just a pre-release eversion -- if it didn't crash, it'd be a released version! ;-) And this add-on is so useful to me, I'd honestly prefer to help you troubleshoot now than risk not having it work when it gets released.

Sorry for not providing the obvious details to start. I'm using Thunderbird 2.0.0.23. This was the first 0.6.0pre version that I tried; prior to this, I was using 0.5.12 (and just about every version up to that from 0.5.2). I contemplated moving to pre5 before logging the bug, but I reviewed the history, and that one bug didn't apply to me, so I expect the behavior will be the same. (But when I go back to 0.6 to reproduce the problems, I will of course use pre5).

comment:3 Changed 10 years ago by Keith S. <mozkeith2@…>

Resolution: fixed
Status: assignedclosed

It must have been something with my PC or my session, because I've upgraded to 0.6.0pre6 and haven't had a crash in several hours, even switching between accounts.

I'm closing this bug for now -- I think the large number of crashes was a fluke. Plus, at this point, if it happens again, I should be able to identify what changes caused it and back them out to validate.

Thanks!

Note: See TracTickets for help on using tickets.