Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#186 closed defect (duplicate)

Virtual Identity plugin blocks automatic attachment of signature

Reported by: Michael Roland <michael.roland@…> Owned by:
Version: Keywords:
Cc:

Description

When the plugin is enabled, the signature file is no longer automatically appended to messages (no matter if it is a new message or a reply to an existing message).

Thunderbird 3.0 (all other plugins disabled, but not uninstalled)

With version 0.5.12:

  1. start a new message
  2. change identity to another (standard) identity that has automatic signature appending enabled
  3. signature is NOT appended
  4. change identity to another (standard) identity that has automatic signature appending enabled
  5. signature IS appended

With version 0.6.0rc1:

  1. start a new message
  2. change identity to another (standard) identity that has automatic signature appending enabled
  3. signature is NOT appended
  4. change identity to another (standard) identity that has automatic signature appending enabled
  5. signature is NOT appended

Note that this defect might be related to ticket #159. Yet, it applies to switching between standard (i.e. predefined by account settings) identites and not to virtual identities (I have not tried this with stored virtual identities).

Kind regards, Michael

Change History (5)

comment:1 Changed 12 years ago by Michael Roland <michael.roland@…>

Concerning version 0.6.0rc1 this is a duplicate to #181

comment:2 Changed 12 years ago by Michael Roland <michael.roland@…>

Here is the log file for Tb3.0, VI0.6.0rc1:

Thunderbird 3.0 (20091204171430; Windows NT 5.1)
 - Deutsches Wörterbuch, erweitert für Österreich de-AT@dictionaries.addons.mozilla.org 1.0.2 [DISABLED]
 - Display Quota {c1ac4523-76c2-9995-adbd-d93bf5141bea} 0.3 [DISABLED]
 - Enigmail {847b3a00-7ab1-11d4-8f02-006008948af5} 1.0 [DISABLED]
 - GeckoTIP {b5431952-4840-11da-9502-00e08161165f} 1.0.0 [DISABLED]
 - Lightning {e2fda1a4-762b-4020-b5ad-a41df1933103} 1.0b2pre [DISABLED]
 - Lightning Nightly Updater (Unofficial) lightning-nightly-updater@olive 0.9.090618 [DISABLED]
 - Mnenhy {bf591015-b599-4125-9428-3cb746ddca31} 0.7.6 [DISABLED]
 - Quicktext {8845e3b3-e8fb-40e2-95e9-ec40294818c4} 0.9.9.9 [DISABLED]
 - Signature Switch {2ab1b709-ba03-4361-abf9-c50b964ff75d} 1.6.4 [DISABLED]
 - URL Link {139a120b-c2ea-41d2-bf70-542d9f063dfd} 2.03.3 [DISABLED]
 - Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.6.0rc1
 - Xpunge {786abda0-fd14-d247-bf69-38b2fc18491b} 0.3 [DISABLED]
--------------------------------------------------------------------------------
## v_identity: mod. FillIdentityList

## v_identity: init.
## v_identity: adapt GenericSendMessage
## v_identity: initSystemStage1.
** v_identity.xml fromPopupItem_clone constructor id='id1'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml identityData setter
** v_identity.xml identityData setter value='id1'
** v_identity.xml identityData setter smtp='smtp1'
** v_identity.xml smtp set to 'smtp1'
** v_identity.xml fromPopupItem_clone constructor id='id2'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id3'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id4'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id7'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER2] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id8'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER2] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id9'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER3] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id10'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER3] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id11'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER3] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id12'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER4] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id13'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER3] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id23'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER5] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id24'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER5] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id20'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER6] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id17'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER6] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id19'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER6] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id14'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER7]  (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id22'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER8] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id15'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id16'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id18'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
** v_identity.xml fromPopupItem_clone constructor id='id5'.
** v_identity.xml fromPopupItem_clone constructor smtp='[PROVIDER1] (outgoing)'.
## v_identity: init done.

## vI_rdfDatasource read rdf from 'file:///C:/[...]/virtualIdentity.rdf'
## v_identity: NotifyComposeFieldsReady
## v_identity: NotifyComposeBodyReady
## v_identity: initSystemStage2.
## vI_smartIdentity: msgComposeType = 0
## vI_storage: getVIdentityFromAllRecipients()
## vI_rdfDatasource: __getRDFResourceForVIdentity: no Recipient given.
## vI_rdfDatasource: findMatchingFilter for .
## vI_rdfDatasource: findMatchingFilter no match found.
## vI_storage: found 0 address(es)

## vI_storage: awOnBlur 'addressCol2#1'
## vI_storage: updateVIdentityFromStorage()
## vI_storage: no recipient found, not checked.

** v_identity.xml msgIdentityCloneElem.doCommand() 
** v_identity.xml identityData setter
** v_identity.xml checkForVirtualIdentity: id24 'Michael Roland <michael.roland@PROVIDER5>'
## vI_identityData: isExistingIdentity: Michael Roland <michael.roland@PROVIDER5> found, id='id24'
## vI_msgIdentityCloneTools: signatureSwitch restore signature
** v_identity.xml identityData setter value='id24'
** v_identity.xml identityData setter smtp='smtp4'
** v_identity.xml smtp set to 'smtp4'

** v_identity.xml msgIdentityCloneElem.doCommand() 
** v_identity.xml identityData setter
** v_identity.xml checkForVirtualIdentity: id20 'Michael Roland <myuser@PROVIDER6>'
## vI_identityData: isExistingIdentity: Michael Roland <myuser@PROVIDER6> found, id='id20'
## vI_msgIdentityCloneTools: signatureSwitch restore signature
** v_identity.xml identityData setter value='id20'
** v_identity.xml identityData setter smtp='smtp6'
** v_identity.xml smtp set to 'smtp6'

** v_identity.xml msgIdentityCloneElem.doCommand() 
** v_identity.xml identityData setter
** v_identity.xml checkForVirtualIdentity: id24 'Michael Roland <michael.roland@PROVIDER5>'
## vI_identityData: isExistingIdentity: Michael Roland <michael.roland@PROVIDER5> found, id='id24'
## vI_msgIdentityCloneTools: signatureSwitch restore signature
** v_identity.xml identityData setter value='id24'
** v_identity.xml identityData setter smtp='smtp4'
** v_identity.xml smtp set to 'smtp4'

Kind regards, Michael

comment:3 Changed 12 years ago by rene

Resolution: duplicate
Status: newclosed

Hi Michael,

there was a problem with synchronizing base and virtual identities. This problem is a duplicate of #181, as you already mentioned. Sorry for the late reaction, I had some problems with my connectivity. The problem should be fixed now with [d804b2377e256b1e49] containing in rc2

Nice regards, Rene

comment:4 Changed 12 years ago by anonymous

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

comment:5 Changed 11 years ago by anonymous

Thank you for sharing. Here are some ways to learn Spanish. Learn Spanish major and more reading, listening and writing. Also use this rosetta stone spanish software to assist you.rosetta stone spanish

Note: See TracTickets for help on using tickets.