Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#209 closed defect (fixed)

duplicating/triplicating messages in inbox

Reported by: anonymous Owned by: rene
Version: 0.6.0rc6 Keywords:
Cc:

Description

with TB3, messages in inbox appear duplicated or triplicated. This seems to happen at a random time, and is fixed by restarting TB.

Change History (9)

comment:1 Changed 10 years ago by rene

Hi,

can you reproduce this with TB3.0.1, why you think this is related to the extension? Are there any error messages showing up in the Error-Console (see Tools menu)? ANy schema about when does it happen?

Nice regards, Rene

comment:2 Changed 10 years ago by anonymous

Confirmed on TB3.0.1

Lots of errors. I've copied a representative selection of them here. All errors are here, but omitted some warnings.

Error: SetupCompactMenuItem is not defined
Source File: chrome://mailtweak/content/messenger.js
Line: 70

window.onSearchInputFocus undefined

ex1:TypeError: folder is null

Warning: Unknown descriptor 'panose-1' in @font-face rule.  Skipped to next declaration.
Source File: imap://whoever@imap.gmail.com:993/fetch%3EUID%3E/INBOX%3E24872
Line: 17

Warning: Unknown property 'mso-style-priority'.  Declaration dropped.
Source File: imap://whoever@imap.gmail.com:993/fetch%3EUID%3E/INBOX%3E24872
Line: 31

Warning: Unknown property 'mso-highlight'.  Declaration dropped.
Source File: imap://whoever@imap.gmail.com:993/fetch%3EUID%3E/INBOX%3E24872
Line: 0

Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird%203/modules/activity/alertHook.js :: anonymous :: line 65"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Thunderbird%203/modules/activity/alertHook.js
Line: 65

Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird%203/modules/activity/alertHook.js :: anonymous :: line 65"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Thunderbird%203/modules/activity/alertHook.js
Line: 65

Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgMailNewsUrl.server]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird%203/modules/activity/alertHook.js :: anonymous :: line 65"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Thunderbird%203/modules/activity/alertHook.js
Line: 65

comment:3 Changed 10 years ago by anonymous

crap - rene, i can't edit my last post. would you mind removing the parts of the errors about that contain my email address? thanks!

comment:4 Changed 10 years ago by anonymous

oh - and, i think it's related to VI because it just started happening after i installed the rc version of VI. Never happened before.

comment:5 Changed 10 years ago by rene

Hi,

(removed email adresses)

can't see any related errors in this log, they usually should be raised by a file like vI_...

Don't see how to investigate this any further, did you find any schema about when it occurs or what you have to do to trigger the effect? Sorry, but currently missing any idea why the interface should be destroyed like that.

Regards, Rene

comment:6 Changed 10 years ago by anonymous

hi rene,

what do you mean by schema?

thanks, alex

comment:7 Changed 10 years ago by rene

Owner: set to rene
Status: newassigned

Hi Alex,

found a way to reproduce this, looking for a solution.

Thanks for the report, nice regards, Rene

comment:8 Changed 10 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi Alex,

catched the problem, it is hopefully fixed in [08cca0ebed9420] contained in 0.6.0rc8. Didn't had the time for heavy testing, so please report if this works for you as expected.

Nice regards and thanks for the report,

Rene

comment:9 Changed 10 years ago by cbhaley@…

I have been seeing this problem for months, usually 3 or 4 times per week. I thought it was related to smart folders, because I fixed it by going to the folder properties and re-selecting the real folders to be included. That process removed the duplicates.

It never occurred to me that it was related to VI. Thank you both!

I will post here if I see the problem again.

Note: See TracTickets for help on using tickets.