Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#22 closed defect (fixed)

selecting an SMTP server

Reported by: towo Owned by: rene
Version: Keywords:
Cc:

Description

I have two mailboxes configured, one with address 1 for home access, one with address 2 for work access. I received a mail for address 1 at my work account (being redirected externally). "Reply" used address 1 properly but also wanted to use the SMTP server of account 1 for sending the mail which is wrong. I have no access to that server while on my work account.

  • Actually, this behaviour seems to comply with what "Ticket #16"

on your project page asked for but as I said this is wrong as a default.

The SMTP server should always be taken from the mailbox the mail was sent to, and should not be selected by the sender address selected for the response.

  • Now browsing through the extensive options, I found "show SMTP menu"

which helps if message delivery would fail otherwise, but the default should still be as I tried to argue above.

Change History (3)

comment:1 Changed 13 years ago by rene

Hi,

can't reproduce your problem, maybe depends on your configuration. Some words about the implemented process to select the SMTP-server. Thunderbird selects some Reply-SenderIdentity?, I expect this is a reasonable choice. Lets call this Reply-SenderIdentity? BaseIdentity?. If you reply to any mail, Smart-Reply checks if the BaseIdentity? has some SMTP-server configured. If, this one is used. If not, the related account which this Identity is part of is searched and the SMTP-server of this account is used. If the account has no configured SMTP-server, the default SMTP-server of Thunderbird is used. So far so good, but this seems not to work in your case. Therefore I included some additional debug-information in [75], just check the next pre-release or the nightly snapshot to see whats going on. Activate the debug-information in the preferences dialog and have a look for something liken "## v_smtpSelector: use SMTP ..." at the beginning of the output.

Regards, Rene

comment:2 Changed 13 years ago by rene

Owner: set to rene

comment:3 Changed 13 years ago by rene

Resolution: fixed
Status: newclosed

done with (pre)release 0.5.0. Added option to use SMTP-extension, this might help you.

regards, Rene

Note: See TracTickets for help on using tickets.