Opened 11 years ago

Closed 11 years ago

#230 closed defect (fixed)

SmartReply doesn't work if main account email address is empty

Reported by: anonymous Owned by:
Version: 0.6.0rc10 Keywords:
Cc:

Description

This is a great addon that I have used for some time. I recently installed it on a new machine running XP and couldn't get the smartReply feature to work. It wouldn't find the email addresses that had been specified in the to: or envelope-to fields.

I compared all of the virtual-identity settings between this machine and my other and they all appeared to the same. I eventually tracked down the difference - on the new machine the Email Address field for the default identity was empty (I had two alternate identities defined under the "manage identities" button. This forces the user to choose an identity before sending a new email rather than having a default.

If I put a character in the "Email Address" field for the account (even a space character) then it would all work correctly and virtual identity would find the addresses again.

This is easy to work around but it would be nice to fix in case other people are seeing the same problem.

regards,John A

Attachments (1)

Noname.jpg (56.0 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by rene

Hi John,

what version of Thunderbird or Seamonkey you are using? Currently I can't check a broader range of versions, but with the ones I use I can't reproduce the initial steps to the problem.

Maybe I got it wrong, but if I remove the name and the email address than the identity will stay there in manage identities, only without name and address. If I use it (even as a bse identity) this might result in some trouble... therefore Thunderbird fills in a default name (whereever this comes from)

Why you are using this setup, what version of TB/SM are you using?

Nice regards, Rene

Changed 11 years ago by anonymous

Attachment: Noname.jpg added

comment:2 in reply to:  1 Changed 11 years ago by anonymous

Replying to rene:

Hi John,

what version of Thunderbird or Seamonkey you are using? Currently I can't check a broader range of versions, but with the ones I use I can't reproduce the initial steps to the problem.

Maybe I got it wrong, but if I remove the name and the email address than the identity will stay there in manage identities, only without name and address. If I use it (even as a bse identity) this might result in some trouble... therefore Thunderbird fills in a default name (whereever this comes from)

Why you are using this setup, what version of TB/SM are you using?

Nice regards, Rene

Hi Rene,

I am using version 3.02 of Thunderbird.

I keep the base identity empty (I have attached a screenshot showing this) and then defined two additional identities with names and email addresses. This means that when I draft a new email the default selected address is blank which forces the user to select an address rather than sending from the default one which may have been incorrect.

It is the smartreply feature that doesn't work. If I receive an email addressed to xxx@… in the To: field then xxx@… is not available as a virtualidentity from which to send a reply (only the additional identities are available.

Let me know if I can help with this any more.

many thanks, John

comment:3 Changed 11 years ago by rene

Hi John,

currently don't know how you are using the "empty sender id" thing, I can't reproduce this nicely here. But cleaned the handling of such a case in [88d969f9006f98e], just try if the next release (0.6.3) works better for you. For in-detail debugging of the reply-case please provide the debug-log. Activate it in the last tab of the preferences dialog and post the result - watch out for confidential information before posting (search/replace with some dummy-text).

Nice regards, Rene

comment:4 Changed 11 years ago by anonymous

Rene,

Your changes in 0.6.3 have fixed the problem. I collected the debug output then realised that I hadn't installed the update. I installed the new version and was then unable to reproduce the problem.

many thanks, John

comment:5 Changed 11 years ago by rene

Resolution: fixed
Status: newclosed

ok, thanks for the report. Nice regards, Rene

Note: See TracTickets for help on using tickets.