Opened 10 years ago

Closed 10 years ago

#231 closed defect (fixed)

XML error prevents editing stored identities

Reported by: xul@… Owned by:
Version: 0.6.0rc11 Keywords:
Cc:

Description

thanks for your great extension since upgrade from 0.6.0rc10 (but as I didn't edited since long time, not sure if it's linked with this new version) I cannot edit stored identities from VI preferences as the window opened contains only error hereafter:

[error] Erreur d'analyse XML : entité non définie Emplacement : chrome://v_identity/content/vI_rdfDataTree.xul Numéro de ligne 246, Colonne 3 : <treecol id="indexCol_filter" label="&vI_rdfDataTree.indexColumn.label;" flex="10"


error

thus a dirty hack editing : [...]content/v_identity/vI_rdfDataTree.xul and commenting lines 246 to 250 (<!-- ... -->)

made the error disappear and editing identities fully functional again, and as far as now didn't prevent any VI other functionalities

Debian GNU/Linux 32 bit TB 3.0.1 from mozilla (not the icedove distro's package)

Attachments (1)

vI_prefDialog.dtd (15.7 KB) - added by xul@… 10 years ago.
corrected & fully translated vi_prefDialog.dtd FR

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by rene

Hi,

thanks for pointing to this problem. This is caused by the incomplete french translation and will be triggered in a similar way for korean and turkish translation. French translation is not yet ready (but nearly complete), if you like to get it done than please join the translation process at www.babelzilla.org

The release of version 0.6 is scheduled for tomorrow, so if the french translation is not ready till than it will be removed (and added later if it gets done). Either way the extension should work than for you again - in english or french, we will see.

Nice regards, Rene

comment:2 Changed 10 years ago by xul@…

thanks, for your quick answer
I joined the translation process at babelzilla,...
using online tool, translated all missing translations
...tried to save work, but browser get stuck infinitedly waiting response (babelzilla site - hemhem... bloated joomla ?) after clicking save button trying to get page:
http://www.babelzilla.org/index.php?option=com_wts&Itemid=0&type=editfileA&extension=4082&language=90&fileid=28258&filetype=dtd
...loosing all work
...tried two times !

So please, tell me what to do next,
I downloaded and could update locally vI_prefDialog.dtd, then attach it here
but I don't want to start smthin not suitable for you and your 0.6 schedule

best regards, antoine

Changed 10 years ago by xul@…

Attachment: vI_prefDialog.dtd added

corrected & fully translated vi_prefDialog.dtd FR

comment:3 Changed 10 years ago by rene

Hi Antoine,

thanks, french translation seems to be complete now, so it will be included in the release. Not using babelzilla too much, I think that all those problems like incomplete translations are results of whatever it is made of. Feels like the translators are themself not aware of their partially incomplete work...

Thanks again,

nice regards, Rene

comment:4 Changed 10 years ago by rene

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.