Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#247 closed defect (invalid)

how to store a default identity for many addresses?

Reported by: newsletter16@… Owned by:
Version: Keywords: question, howto
Cc:

Description

I would like to define a filter to map all recipients at a certain domain to a special identity. I tried "filter" and "email" types of storage entries with addresses like "@example.com", "*@example.com", ".*@example\.com" - but none worked. What can I do?

Change History (3)

comment:1 Changed 10 years ago by rene

Hi,

the best way is to activate the debug output and see whats going on in your case.

There should be something like this

## vI_storage: getVIdentityFromAllRecipients()
## vI_rdfDatasource: readVIdentityFromRDF no data found.
## vI_rdfDatasource: findMatchingFilter for recipient@example.com.
## vI_rdfDatasource: findMatchingFilter, compare with 'example.com'
## vI_rdfDatasource: findMatchingFilter found stored data.
## vI_rdfDatasource: email='identity@example.com' fullName='mynewidentity' id='null' smtp='vI_noStoredSMTP'
## vI_rdfDatasource: extras:
## identityCollection:   add new address to result: mynewidentity <identity@example.com>
## vI_storage: found 1 address(es)
## vI_smartIdentity: SmartReply skipped, Identities in Storage found.
## vI_smartIdentity: merged SmartReply & Storage, 1 address(es) left
## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='true'
## vI_identityData: isExistingIdentity: mynewidentity <identity@example.com> not found
## changeIdentityToSmartIdentity selectedValue=0: 'mynewidentity <identity@example.com>' (,)

If unsure and you can't it to work, please post the debug-output of your case and I will see what I can do. Ensure that you don't post any confidential information - use search&replace before posting.

Nice regards, Rene

comment:2 Changed 10 years ago by newsletter16@…

Resolution: invalid
Status: newclosed

Hi Rene, I think I found the cause: the "filter" storage type does not understand placeholders like *@example.com and does also not recognize regular expressions like .*@example.com$ and even has problems if there is an @ sign in the filter string. But it does work (in a limited way) when I only put the domain name, e.g. "example.com".

I would prefer using regular expressions because if the domain name occurs as local part of another domain's email address (unlikely but imaginable), the filter would be applied!

Thanks for pointing me to the debug console, it helped me understand what VI does.

comment:3 Changed 10 years ago by newsletter16@…

I just found the page https://www.absorb.it/virtual-id/wiki/docSmartReply on which the "filter" functionality is described. In my case, I just had to use the following filter definition (regular expression):

/@example.com$/

So there is no problem using regexes. Good software, but it could use some help texts (e.g. tooltips) in it! :-)

Note: See TracTickets for help on using tickets.