Opened 9 years ago

Closed 9 years ago

#265 closed defect (fixed)

replying to message that is replying to my virtual id

Reported by: virtualidentity@… Owned by: rene
Version: Keywords:
Cc:

Description

Get popup that says:

Virtual Identity Error: Can't change Identity before Sending.

and asks me to report here.

This when I have sent a message using a virtual identity to person X. X replies to me, back to my virtual id. I then reply to that message back to X.

If I click the identity pulldown and manually select the virtual identity, it works.

version 0.6.6 (which isn't available in the bug reporting menu)

Under Fedora 12 Thunderbird 3.0.4. Has been happening for month or so.

Change History (3)

comment:1 Changed 9 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

please activate the debug-output (last tab in preferences dialog) and reproduce the problem-situation. The trace will hopefully tell me whats going on - please think of search/replace any confidential information before posting here.

I might be offline for a while, please stay patient, nice regards,

Rene

comment:2 Changed 9 years ago by virtualidentity@…

Replaced email addresses and full names, but otherwise as copied from test that fails w/ popup.

Thanks.

TThunderbird 3.0.4 (20100430104558; Linux i686)

  • Adblock Plus {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} 1.2
  • CompactHeader? {58D4392A-842E-11DE-B51A-C7B855D89593} 1.2.2
  • ConfigDate? {782E3D25-61FD-4997-AA8F-D3F18FA92ECC} 0.7
  • Extra Folder Columns extra-cols@… 0.4 [DISABLED]
  • header scroll extension {F8147CF4-B9E3-445B-AA87-081ED66548FA} 0.3.2 [DISABLED]
  • Image Zoom {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68} 0.4.4
  • Mail Redirect {CC3C233D-6668-41bc-AAEB-F3A1D1D594F5} 0.7.4
  • Quote Colors {B274D460-4DF9-454c-AC69-CA71398D7498} 0.3
  • Track Package {3f669128-5ad3-4053-ad9b-1afc4ea24c28} 3.1
  • Update Notifier {95f24680-9e31-11da-a746-0800200c9a66} 0.1.5.5
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.6.6
  • Xpunge {786abda0-fd14-d247-bf69-38b2fc18491b} 0.4

## v_identity: composeDialog reopened. (msgType 6) v_identity.xml identityData setter v_identity.xml identityData setter done.' ## v_identity: everything cleaned. ## v_identity: initSystemStage1. v_identity.xml identityData setter v_identity.xml smtp set to 'smtp1' v_identity.xml resultingID: fullName='My Full Name' email='email@…' smtp='smtp1' id='id1' existingID='true' v_identity.xml identityData setter done.' ## v_identity: reopen done. ## v_identity: NotifyComposeFieldsReady? ## v_identity: NotifyComposeBodyReady? ## v_identity: initSystemStage2. ## vI_smartIdentity: msgComposeType = 6 ## vI_smartIdentity: Reply() ## vI_storage: getVIdentityFromAllRecipients() ## vI_rdfDatasource: readVIdentityFromRDF found stored data. ## vI_rdfDatasource: email='email@…' fullName='My Short Name' id='null' smtp='vI_noStoredSMTP' ## vI_rdfDatasource: extras: ## identityCollection: add new address to result: My Short Name <email@…> ## vI_rdfDatasource: findMatchingFilter for Recipient Full Name <toemail@…>. ## vI_rdfDatasource: findMatchingFilter no match found. ## vI_storage: found 1 address(es) ## vI_smartIdentity: SmartReply? skipped, Identities in Storage found. ## vI_smartIdentity: merged SmartReply? & Storage, 1 address(es) left ## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='true' ## vI_identityData: isExistingIdentity: My Short Name <email@…> found, id='id1' ## vI_smartIdentity: found existing Identity, use without interaction. ## changeIdentityToSmartIdentity selectedValue=0: 'My Short Name <email@…>' (My Full Name <email@…>,)

v_identity.xml msgIdentityCloneElem.doCommand() v_identity.xmlcopy selected Menu-Value from clone to orig. Searching for id=id1 v_identity.xml identityData setter v_identity.xml previousID: fullName='My Full Name' email='email@…' smtp='smtp1' id='id1' existingID='true' v_identity.xml newID: fullName='My Short Name' email='email@…' smtp='vI_noStoredSMTP' id='id1' existingID='null' v_identity.xml checkForVirtualIdentity: id1 'My Full Name <email@…>' ## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='false' ## vI_identityData: isExistingIdentity: My Short Name <email@…> found, id='id4' ## vI_msgIdentityCloneTools: signatureSwitch restore signature

-- missing signatureSwitch extension?

v_identity.xml resultingID: fullName='My Short Name' email='email@…' smtp='vI_noStoredSMTP' id='id1' existingID='null' v_identity.xml identityData setter done.' v_identity.xml smtp set to 'smtp1' v_identity.xml checkForVirtualIdentity: id1 'My Full Name <email@…>' ## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='false' ## vI_identityData: isExistingIdentity: My Short Name <email@…> found, id='id4' ## vI_msgIdentityCloneTools: signatureSwitch restore signature

-- missing signatureSwitch extension?

## v_identity: VIdentity_GenericSendMessage ## vI_storage: ---------------------------------------------------------- ## vI_storage: storeVIdentityToAllRecipients() ## vI_storage: updateStorageFromVIdentity. ## vI_storage: updateStorageFromVIdentity dontUpdateMultipleNoEqual='false' ## vI_rdfDatasource: readVIdentityFromRDF found stored data. ## vI_rdfDatasource: email='email@…' fullName='My Short Name' id='null' smtp='vI_noStoredSMTP' ## vI_rdfDatasource: extras: ## vI_rdfDatasource: findMatchingFilter for Recipient Full Name <toemail@…>. ## vI_rdfDatasource: findMatchingFilter no match found. ## vI_storage: ----------------------------------------------------------

## vI_identityData GenericSendMessage? Final Check ## vI_identityData currentIdentity: fullName='My Full Name' email='email@…' smtp='smtp1' ## vI_identityData virtualIdentityData: fullName='My Short Name' email='email@…' smtp='smtp1'

## vI_identityData failed check for fullName.

comment:3 Changed 9 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi,

thanks for your informative report, finally found the problem with your help. If there was a second identity with the same settings except a different Full Name, the problem was triggered. Should be fixed in [b466b2c3ab0dbeeb462], which will be part of upcoming 0.6.7.

Thanks and nice regards, Rene

Note: See TracTickets for help on using tickets.