Opened 11 years ago

Last modified 10 years ago

#276 reopened defect

No mail sending possible after selecting different identity

Reported by: awolf+virtualidentity@… Owned by: rene
Version: 0.6.8 Keywords:
Cc:

Description

When composing a new mail, Virtual Identity selects an identity for me. As this is the wrong identity, I manually select a different one (both identities are "real" ones, i.e. were not created by VI).

When I now try to send the e-mail, nothing happens. I can't even save it in the IMAP Drafts folder, Thunderbird simply does not react to any button click. I can only close the email and loose it completely.

This is definitely reproducable for the said constellation. When sending the email with the original sender identity (which has been selected by VI), everything works as expected.

Change History (5)

comment:1 Changed 11 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

please check the Javascript Error Console (Tools) Menu for any related error messages - there should be some. Hope to get the problem solved,

Nice regards, Rene

comment:2 Changed 10 years ago by awolf+virtualidentity@…

Ok, the problem just occured again, and this was printed in the error log:

Fehler: initializeHeaderViewTables is not defined
Quelldatei: chrome://v_identity/content/vI_getHeader.js
Zeile: 199

There are some more lines, but this was the only one that was obviously related to VI.

comment:3 Changed 10 years ago by rene

Hi, which version of Thunderbird you are using? Seems to be a compatibility-problem with the specific version, because it's running fine on TB 3.+

Nice regards, Rene

comment:4 Changed 10 years ago by anonymous

Resolution: worksforme
Status: assignedclosed

closing the ticket, please reopen if still relevant

comment:5 Changed 10 years ago by awolf+virtualidentity@…

Resolution: worksforme
Status: closedreopened

From time to time, this still occurs. I think it is related to an empty line in the recipients list, which causes confusion when selecting a virtual identity. I could not really verify this, but it is the only thing I noticed in all situations when VI "crashed" my Thunderbird.

Note: See TracTickets for help on using tickets.