Opened 10 years ago

Closed 10 years ago

#290 closed defect (invalid)

Virtual identity and compact header don't play nice together

Reported by: cbhaley@… Owned by: rene
Version: 0.6.8 Keywords:
Cc:

Description

I have been using both virtual identity and compact header together for some time. However, yesterday I accepted the 1.3.0beta1 update of compact header, and virtual identity stopped working (sometimes). Instead of doing smart_reply, I now (sometimes) get smart_draft.

I know that this isn't really your problem, but I thought you might want to know about it.

The (sanitized) debug log on a failure case shows:

Thunderbird 3.1.3 (20100825123352; Windows NT 6.1)
 - Buttons! {a3ba6d6b-e8de-465a-b155-f87586e47039} 0.5.3.2 [DISABLED]
 - Change quote and reply format {f6090211-2004-44d8-9090-be3c2adfd66f} 0.6.4.3
 - CompactHeader {58D4392A-842E-11DE-B51A-C7B855D89593} 1.3.0beta1
 - ConfigDate {782E3D25-61FD-4997-AA8F-D3F18FA92ECC} 0.7
 - Confirm-Address confirm-address@kenmaz.net 1.2.4
 - Dictionnaire français «Classique» fr-FR@dictionaries.addons.mozilla.org 3.5
 - Enigmail {847b3a00-7ab1-11d4-8f02-006008948af5} 1.1.2 [DISABLED]
 - External Editor {11d1a081-b8c3-4002-af38-6ad3e899fdfa} 0.9.0
 - FoxClocks {d37dc5d0-431d-44e5-8c91-49419370caa1} 2.6.18
 - FoxyProxy Standard foxyproxy@eric.h.jung 2.22.1
 - Lightning {e2fda1a4-762b-4020-b5ad-a41df1933103} 1.0b2
 - QuoteAndComposeManager {ce1c1a31-4ec2-484f-8099-e2cb0f381c21} 0.3.15
 - Run Filters on Folder Button filter_folder_button@kisuk.kim 1.1
 - Signature Switch {2ab1b709-ba03-4361-abf9-c50b964ff75d} 1.6.6
 - Toggle HTML {0253f527-d137-4a7e-82c3-02ed32a48ea3} 1.1.15 [DISABLED]
 - Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.6.8
 - gContactSync gContactSync@pirules.net 0.2.17
--------------------------------------------------------------------------------
## v_identity: composeDialog reopened. (msgType 6)
** v_identity.xml identityData setter
** v_identity.xml identityData setter done.'
## v_identity: everything cleaned.
## v_identity: initSystemStage1.
** v_identity.xml identityData setter
** v_identity.xml smtp set to 'smtp3'
** v_identity.xml resultingID: fullName='CHANGE ME CHANGE ME CHANGE ME' email='CHANGE_ME-CHANGE_ME@noWHEREEE.comm' smtp='smtp3' id='id2' existingID='true'
** v_identity.xml identityData setter done.'
## v_identity: reopen done.
## v_identity: NotifyComposeFieldsReady
## v_identity: NotifyComposeBodyReady
## v_identity: initSystemStage2.
## vI_smartIdentity: msgComposeType = 6
## vI_smartIdentity: Reply()
## vI_smartIdentity: reply on non-received (sent?) mail. Using SmartDraft. 
## vI_smartIdentity: ReplyOnSent() (rules like SmartDraft)
## vI_smartIdentity: __SmartDraftOrReplyOnSent()
## identityCollection:   add new address to result: XXX <XXX@YYY>
## vI_smartIdentity: sender 'XXX <XXX@YYY>'
## vI_storage: getVIdentityFromAllRecipients()
## vI_rdfDatasource: readVIdentityFromRDF no data found.
## vI_rdfDatasource: findMatchingFilter for XXX <XXX@YYY>.
## vI_rdfDatasource: findMatchingFilter, compare with 'ZZZ'
## vI_rdfDatasource: findMatchingFilter, compare with 'ZZZ2'
## vI_rdfDatasource: findMatchingFilter, compare with 'ZZZ3'
## vI_rdfDatasource: findMatchingFilter no match found.
## vI_storage: found 0 address(es)
## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='true'
## vI_identityData: isExistingIdentity: XXX <XXX@YYY> not found
## changeIdentityToSmartIdentity selectedValue=0: 'XXX <XXX@YYY>' (,)

** v_identity.xml msgIdentityCloneElem.doCommand() 
** v_identity.xmlcopy selected Menu-Value from clone to orig. Searching for id=null 
** v_identity.xml identityData setter
** v_identity.xml previousID: fullName='CHANGE ME CHANGE ME CHANGE ME' email='CHANGE_ME-CHANGE_ME@noWHEREEE.comm' smtp='smtp3' id='id2' existingID='true'
** v_identity.xml newID: fullName='XXX <XXX@YYY>' smtp='vI_noStoredSMTP' id='null' existingID='null'
** v_identity.xml checkForVirtualIdentity: id2 'CHANGE ME CHANGE ME CHANGE ME <CHANGE_ME-CHANGE_ME@noWHEREEE.comm>'
## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='false'
## vI_identityData: isExistingIdentity: XXX <XXX@YYY> not found
## vI_msgIdentityCloneTools: signatureSwitch hide/remove signatures
** v_identity.xml resultingID: fullName='XXX <XXX@YYY>' smtp='vI_noStoredSMTP' id='id2' existingID='null'
** v_identity.xml identityData setter done.'
** v_identity.xml smtp set to 'smtp3'
** v_identity.xml checkForVirtualIdentity: id2 'CHANGE ME CHANGE ME CHANGE ME <CHANGE_ME-CHANGE_ME@noWHEREEE.comm>'
## vI_identityData: isExistingIdentity: ignoreFullNameWhileComparing='false'
## vI_identityData: isExistingIdentity: XXX <XXX@YYY> not found
## vI_msgIdentityCloneTools: signatureSwitch hide/remove signatures

Change History (2)

comment:1 Changed 10 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

interesting to hear about those problems. Tried the CompactHeader extension for a test, but could not reproduce the problem. Seems like the "received"-header is not detected in your case.

## vI_smartIdentity: reply on non-received (sent?) mail. Using SmartDraft. 

Do the received mails really conatin a received-header? There should be a line like

## vI_getHeader: found header: received  ...stored to recognize received mail

when you select the mail in your 3-pane window (and debug-log is activated). Are you getting this line (if the problem is somehow reproducible)? And what does the source-view of the mail says, is there any received-header?

Otherwise I have still no idea what causes the problem, but will keep the Compact-Header extension activated for a while to check.

Regards and thanks for the report, Rene

comment:2 Changed 10 years ago by rene

Resolution: invalid
Status: assignedclosed

closing ticket by now, please reopen and provide requested info if still relevant.

Note: See TracTickets for help on using tickets.