Opened 10 years ago

Closed 9 years ago

#305 closed defect (fixed)

Cannot open preferences/options window

Reported by: archaeopteryx@… Owned by: rene
Version: 0.6.8 Keywords:
Cc:

Description

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

Virtual Identity 0.6.8

When I try to open the add-on's options window by pressing the 'Options' button in the add-ons manager, a small window opens with no content and immediately closes itself. The error console shows:

Error: No Element found Source file: chrome://v_identity/content/vI_prefDialog.xul Line: 1

Change History (9)

comment:1 Changed 10 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

sounds strange. But currently on vacation it will be difficult to debug this. Does the same happen with other versions of Thunderbird too? Did it occured after a good while of using TB 3.1.9 or did it occured just after upgrading?

Sorry for not beeing too helpful, I'll be back on my desk in April and check the issue...

Nice regards, Rene

comment:2 Changed 10 years ago by Wayne Mery <vseerror@…>

Also see this issue. But only one console message per Thunderbird session.

Also see ... Warning: Failed to load overlay from chrome://v_identity/content/vI_prefDialog.xul. Source File: chrome://v_identity/content/vI_prefDialog_TB3.xul Line: 0

comment:3 Changed 10 years ago by archaeopteryx@…

I don't know since when this has been broken because I haven't used the settings for months.

If I shall test something with DOM Inspector or Javascript Debugger or mail you some files in April, just tell me.

comment:4 Changed 10 years ago by rene

Hi,

ok. Till this time you might change the options in the extended config dialog, somewhere under the main thunderbird preferences. But be aware that you might screw the whole function of the extension, best to work on a backup of your prefs.js (found in your configuration folder).

Back in April, Rene

comment:5 Changed 10 years ago by rene

Hi,

back at home I checked TB version 3.1.9 on Linux and Windows, but preferences dialog opens everytime in my installation. Still trying to find the problem, sorry for the further delay. Stay tuned...

Nice regards, Rene

comment:6 Changed 10 years ago by virtualid@…

same here like wayne mery, but i see those 3 buttons. but nothing else. like a transparent window with just those 3 buttons "ok", "cancel", "online-help" (possibly different naming, as mines are in german...). on win7 32bit, tb 3.1.9

thanx for your work. great addon! ivo

comment:7 Changed 10 years ago by illia.bobir@…

Same here. When I try to open the options dialog from the add-on manager add-on list I get a small empty window for a second and then it is gone and nothing. If I do Tools->Virtual Identity->Settings I just see three buttons: "OK", "Cancel" and "Online-help" floating with no window.

Thunderbird 3.1.9. Virtual Identity 0.6.3 and 0.7.0pre2.

comment:8 in reply to:  7 Changed 10 years ago by illia.bobir@…

Replying to illia.bobir@…:

Same here. When I try to open the options dialog from the add-on manager add-on list I get a small empty window for a second and then it is gone and nothing. If I do Tools->Virtual Identity->Settings I just see three buttons: "OK", "Cancel" and "Online-help" floating with no window.

Thunderbird 3.1.9. Virtual Identity 0.6.3 and 0.7.0pre2.

Here are all the Virtual Identity related messages in the error console:

Error: no element found
Source file: chrome://v_identity/content/vI_prefDialog.xul
Line: 1
 ----------
Warning: Failed to load overlay from chrome://v_identity/content/vI_prefDialog.xul.
Source file: chrome://v_identity/content/vI_prefDialog_TB3.xul
 ----------
Error: vI_prefDialog is not defined
Source file: chrome://v_identity/content/vI_prefDialog_TB3.xul
Line: 1
 ----------
Error: vI_prefDialog is not defined
Source file: chrome://v_identity/content/vI_prefDialog_TB3.xul
Line: 1

comment:9 Changed 9 years ago by rene

Resolution: fixed
Status: assignedclosed

fixed with 0.8.0pre for TB >= 5.0 or SM >= 2.1. It's only a (yet unstable) preview, but because of some change in the interface will surely fix this bug.

Regards, sorry for no other way around this problem, Rene

Note: See TracTickets for help on using tickets.