Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#314 closed defect (duplicate)

Error: Can't change Identity before Sending.

Reported by: virtual-id2eran@… Owned by:
Version: 0.6.8 Keywords:
Cc:

Description

When sending emails to certain addresses, I always get this error: "Error: Can't change Identity before Sending.". Same when saving as draft.

The problem has been present for (at least) many months, including Virtual Identity 0.6.8.

If I click the SMTP server box and choose "Default", then I can send or save the message (even though the SMTP server was *already* at "Default"). Likewise if I choose a different Virtual ID.

The JavaScript? Error Console is empty.

Here's the debug log (with names search&replaced; the original names and addresses don't have any funny characters or unusual spaces):

=============== Thunderbird 3.1.10 (20110428195623; Linux x86_64)

  • Attachment Reminder attachmentreminder@… 0.3.10 [DISABLED]
  • Auto Zip Attachments AutoZipAttachments?@tomer.com 0.6.2 [DISABLED]
  • BiDi? Mail UI {54e72d7b-ed31-4736-854f-f517358f21ee} 0.9.5
  • Colored Diffs {282C3C7A-15A8-4037-A30D-BBEB17FFC76B} 0.6.2010.06.25.16.16.59
  • CompactHeader? {58D4392A-842E-11DE-B51A-C7B855D89593} 1.2.4 [DISABLED]
  • Display mailing list header {F8147CF4-B9E3-445B-AA87-081ED66548F9} 0.3.2 [DISABLED]
  • EditHtml? {4a104f95-6584-4f9d-81cf-8071c43d5510} 0.1.3 [DISABLED]
  • Enigmail {847b3a00-7ab1-11d4-8f02-006008948af5} 1.1.2 [DISABLED]
  • Expression Search / Google Mail UI {03EF8A6E-C972-488f-92FA-98ABC2C9F8B9} 0.8.1 [DISABLED]
  • Hebrew spell-checking dictionary (from HSpell) he@… 1.1.0.1
  • Image Zoom {1A2D0EC4-75F5-4c91-89C4-3656F6E44B68} 0.4.6
  • keyconfig keyconfig@dorando 20110522 [DISABLED]
  • Launchy launchy@… 4.4.0 [DISABLED]
  • Lightning {e2fda1a4-762b-4020-b5ad-a41df1933103} 1.0b2 [DISABLED]
  • Linky linky@… 2.7.1 [DISABLED]
  • Maximize Message Pane {CC1FC7EB-79F7-4A28-B12C-731304F16E53} 1.1.11
  • MboxImport? {3ed8cc52-86fc-4613-9026-c1ef969da4c3} 0.5.6 [DISABLED]
  • MessageID-Finder {179b29a7-8730-4788-8862-57d898500a6e} 2.0.0 [DISABLED]
  • Mnenhy {bf591015-b599-4125-9428-3cb746ddca31} 0.7.5 [DISABLED]
  • nntpthreads {6e491e10-baa5-49c4-bdbe-26fd9a53c901} 0.1.0 [DISABLED]
  • Nostalgy nostalgy@… 0.2.26 [DISABLED]
  • Open Long Url {10F04CC7-50E2-4564-99EC-6E9B27985908} 0.2.3 [DISABLED]
  • Quote Colors {B274D460-4DF9-454c-AC69-CA71398D7498} 0.3
  • Remember Mismatched Domains {c8961d25-7d90-4c7e-893b-400a5c882920} 1.4.6 [DISABLED]
  • Remove Duplicate Messages (Alternate) {a300a000-5e21-4ee0-a115-9ec8f4eaa92b} 0.3.7
  • Seek seek@… 1.0.1 [DISABLED]
  • SmtpSelect? {837cbf1c-a15b-11da-957a-00e08161165f} 1.1.0 [DISABLED]
  • Toggle Word Wrap {cafe3945-058e-47e3-87f8-75bc120b9638} 1.7
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.6.8
  • XNote xnote@… 2.1.0 [DISABLED]

## v_identity: composeDialog reopened. (msgType 0) v_identity.xml identityData setter v_identity.xml identityData setter done.' ## v_identity: everything cleaned. ## v_identity: initSystemStage1. v_identity.xml identityData setter v_identity.xml smtp set to v_identity.xml resultingID: fullName='SenderName?' email='sender@…' smtp='vI_useDefaultSMTP' id='id2' existingID='true' v_identity.xml identityData setter done.' ## v_identity: initSystemStage2. ## vI_smartIdentity: msgComposeType = 0 ## vI_storage: getVIdentityFromAllRecipients() ## vI_rdfDatasource: getRDFResourceForVIdentity: no Recipient given. ## vI_rdfDatasource: findMatchingFilter for . ## vI_rdfDatasource: findMatchingFilter no match found. ## vI_storage: found 0 address(es) ## v_identity: reopen done.

## vI_storage: awOnBlur 'addressCol2#1' ## vI_storage: updateVIdentityFromStorage() ## vI_rdfDatasource: readVIdentityFromRDF found stored data. ## vI_rdfDatasource: email='sender@…' fullName='SenderName?' id='null' smtp='vI_noStoredSMTP' ## vI_rdfDatasource: extras: ## vI_rdfDatasource: findMatchingFilter for RecipientName? <recipient@…>. ## vI_rdfDatasource: findMatchingFilter no match found. ## vI_storage: updateVIdentityFromStorage add found Identities to CloneMenu?. ## vI_storage: using data from direct match ## vI_storage: compare with current Identity ## vI_storage: updateVIdentityFromStorage check if storage-data matches current Identity. ## vI_storage: updateVIdentityFromStorage doing nothing - equals current Identity.

## vI_storage: awOnBlur 'addressCol2#2' ## vI_storage: updateVIdentityFromStorage() ## vI_storage: no recipient found, not checked.

## v_identity: VIdentity_GenericSendMessage ## vI_storage: ---------------------------------------------------------- ## vI_storage: storeVIdentityToAllRecipients() ## vI_storage: updateStorageFromVIdentity. ## vI_storage: updateStorageFromVIdentity dontUpdateMultipleNoEqual='false' ## vI_rdfDatasource: readVIdentityFromRDF found stored data. ## vI_rdfDatasource: email='sender@…' fullName='SenderName?' id='null' smtp='vI_noStoredSMTP' ## vI_rdfDatasource: extras: ## vI_rdfDatasource: findMatchingFilter for RecipientName? <recipient@…>. ## vI_rdfDatasource: findMatchingFilter no match found. ## vI_storage: ----------------------------------------------------------

## vI_identityData GenericSendMessage? Final Check ## vI_identityData currentIdentity: fullName='SenderName? ' email='sender@…' smtp='vI_useDefaultSMTP' ## vI_identityData virtualIdentityData: fullName='SenderName?' email='sender@…' smtp='vI_useDefaultSMTP'

## vI_identityData failed check for fullName.

Attachments (1)

id2 (4.8 KB) - added by virtual-id2eran@… 9 years ago.
Debug log (same as in initial report)

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by virtual-id2eran@…

Attachment: id2 added

Debug log (same as in initial report)

comment:1 Changed 9 years ago by rene

Resolution: duplicate
Status: newclosed

Hi,

it's a problem with some space around your Full Name in Thinderbirds Accoutn Settings. Please remove them or use the preview-Version of 0.7.0. Duplicate of #281,

Regards, Rene

comment:2 Changed 9 years ago by virtual-id2eran@…

Confirmed, there was an extra space after the Full Name, which I somehow missed. Thanks for the quick response and sorry for the dup report.

Note: See TracTickets for help on using tickets.