Opened 8 years ago

Closed 8 years ago

#333 closed defect (fixed)

Support for Thunderbird Conversations

Reported by: absorb.it@… Owned by: rene
Version: 0.8.0 Keywords:
Cc:

Description

The Mozilla-endorsed extension Thunderbird Conversations provides a view of all messages in a thread from a single Message Pane. Additionally, it provides a quickreply feature in which the user can reply to a mail without opening a separate Composer window. The user does have the option of opening a separate composer window if he desires, however.

With Thunderbird Conversations installed, Virtual Identity does not copy the To address of a mail to the From address of a reply. This is broken in both the quickreply interface and when opening the reply in a Compose window. In both cases, the To address of the original message is put in a CC field of the reply. Please integrate support for Conversation View in Virtual Identity.

To reproduce: 1) Install both Virtual Identity and Thunderbird Conversations. 2) Receive and email addressed to an address for which you do not have an Identity configured. 3) Click Reply

It can be seen that the original To address is now in the CC field, and the To field is set to a configured identity.

Change History (16)

comment:1 Changed 8 years ago by anonymous

Here is the corresponding Thunderbird Conversations feature request, so that the devs may collaborate: https://github.com/protz/GMail-Conversation-View/issues/346

comment:2 Changed 8 years ago by rene

Resolution: worksforme
Status: newclosed

implemented since 0.8.0pre1 [cb01622e1fbe5] and should therefore work with Conversation. Please reopen if this does not work for you and provide some debug information (see https://www.absorb.it/virtual-id/wiki/FAQ#debuggingaproblemsendingdebug-output )

Thanks and nice regards, Rene

comment:3 Changed 8 years ago by absorb.it@…

Resolution: worksforme
Status: closedreopened

Thanks, Rene, but I am in fact using VI 0.8.0 (virtual_identity-0.8.0-tb+sm.xpi) on Thunderbird 5.0 (release version) and Thunderbird Conversations 2.0.8. The debug console gave no errors when pressing Reply on a mail, and yet the VI identity is not properly used. What actions should I perform to cause an error to occur? Would you like a screencast of the happening?

Thanks.

comment:4 Changed 8 years ago by rene

Owner: set to rene
Status: reopenednew

Hi,

thought the problems had been solved with the implemented fixes... I will check this again, but it will take a while - stay tuned for the next weeks.

sorry for the delay, regards, Rene

comment:5 Changed 8 years ago by Dotan Cohen <absorb.it@…>

Thanks, Rene! You know how much I appreciate your hard work and dedication to Virtual Identity users. I'll be here to test if you need.

Have a great week.

comment:6 Changed 8 years ago by jonathan

Cool! I have a plugin mechanism for Thunderbird Conversations so if that makes your life easier, I can add a new kind of notification you can listen to and act upon (like, say, I just setup a new composition session).

See https://github.com/protz/GMail-Conversation-View/blob/master/modules/plugins/enigmail.js for an example. Currently we don't have hooks for plugins that interact with the quick reply, but that would be easy to fix.

Here's how we notify plugins about an event: https://github.com/protz/GMail-Conversation-View/blob/master/modules/message.js#L1048 Here's where you could add a hook so that you receive notifications about a composition session being set up: https://github.com/protz/GMail-Conversation-View/blob/master/content/stub.compose-ui.js#L376

I don't know exactly what kind of notification you need, but I'll gladly consider any pull request on GitHub?.

Cheers,

jonathan

comment:7 Changed 8 years ago by rene

Hi,

working on it - will be part of next 0.8-version. Stay tuned,

Rene

comment:8 Changed 8 years ago by rene

Status: newassigned

Hi,

just hacked for a while and now version 0.9pre1 is ready to support conversation. It's heavily changed and not tested, but should be a good base to get the things done.

As you (jonathan) expected I do require a lot more triggers from Thunderbird Conversation, as you can see in the attached diff (which was used together with some alpha-version of your extension).

Can you implement the required triggers or do you have better places / styles for them?

virtualIdentity-0.9pre1 modifiedConversationsAlpha.xpi conversation_diff.txt

Regards, Rene

Last edited 8 years ago by rene (previous) (diff)

comment:10 Changed 8 years ago by rene

Hi,

another test release, created "pull request" to include required code into conversation. Test versions can be found as virtual_identity-0.9pre2-tb+sm.xpi and conversationsAlpha2.xpi

feedback welcome - be aware that this is all alpha code, not really tested.

Regards, Rene

comment:11 Changed 8 years ago by anonymous

Thanks. I'm doing the bad thing and using this on my production system to give it a good workout.

When actually trying to send mail from the quick reply, I get this message: "An error occurred while sending mail. The mail server responded: <@dotancohen.com>: no local part. Please verify that your email address is correct in your Mail preferences and try again."

I can then open the full Compose window and send the mail successfully from there.

comment:12 Changed 8 years ago by rene

Hi Dotan,

if you can, please provide the debug-log of the sending-problem. See FAQ for details how to do this, and send by email or usefully replace email addresses before posting here.

Thanks for testing, looking forward to get this done, Rene

comment:13 Changed 8 years ago by absorb.it@…

Thunderbird 6.0 (20110812165849; Linux i686)
--------------------------------------------------------------------------------
## getHeader: found header: envelope-to[:1] - stored as 'laurieotto@--.com'
## getHeader: found header: received  ...stored to recognize received mail
## getHeader: found header: to[:1] - stored as 'Dotan Cohen <laurieotto@--.com>'
addon: Search for Sender 1.2
addon: Google Calendar Tab 3.8 [DISABLED]
addon: Silvermel and Charamel XT 1.4.3
addon: BiDi Mail UI 0.9.6
addon: WAT 1.3.1
addon: Hebrew spell-checking dictionary (from HSpell) 1.1.0.1
addon: Tiny Menu 2.0.4
addon: Maximize Message Pane 1.1.12
addon: Muttator 1.0
addon: Right Encoding 0.2.5
addon: Global Menu Bar integration 1.0.7
addon: New Mail Attention 1.2.1
addon: Quicktext 0.9.11.2
addon: Tag Toolbar 0.8.35
addon: Enigmail 1.3.2
addon: Virtual Identity 0.9pre2
addon: Thunderbird Conversations 2.1rc
addon: Silvermel 1.4.3 [DISABLED]
addon: Charamel 1.4.3 [DISABLED]
addon: Hebrew (IL) Language Pack 3.1.309 [DISABLED]
addon: Default 6.0
addon: English (GB) Language Pack 7.0 [DISABLED]
addon: Adobe Reader 9.4 
addon: IcedTea-Web Plugin (using IcedTea-Web 1.1.1 (1.1.1-0ubuntu1~11.04.1))  [DISABLED]
addon: Google Talk Plugin  [DISABLED]
addon: Google Talk Plugin Video Accelerator  [DISABLED]
addon: Skype Buttons for Kopete  [DISABLED]
addon: Shockwave Flash  [DISABLED]

comment:14 Changed 8 years ago by rene

right, but if you use quick-reply, and later press the send button (and let sending fail)? This isn't the complete log, or is it? Are there any related error messages in the Tools->(DevlopmentTools?)->Error Console

Thanks, regards, Rene

comment:15 Changed 8 years ago by absorb.it@…

right, but if you use quick-reply, and later press the send button (and let sending fail)?

I did do that. I noticed that nothing new was added after pressing the Send button.

This isn't the complete log, or is it?

It is the complete log.

Are there any related error messages in the Tools->(DevlopmentTools??)->Error Console

I just tried on another message. There was nothing relevant in the Error Console (I did check that for the previous message as well) but there was more output in the debug-log:

Thunderbird 6.0 (20110812165849; Linux i686)
--------------------------------------------------------------------------------
## getHeader: found header: envelope-to[:1] - stored as 'ido.coh@--.com'
## getHeader: found header: received  ...stored to recognize received mail
## getHeader: found header: to[:1] - stored as 'Dotan Cohen <ido.coh@--.com>, Dotan Cohen <dotancohen@--.com>, dotancohen@--.org'
addon: Search for Sender 1.2
addon: Google Calendar Tab 3.8 [DISABLED]
addon: Silvermel and Charamel XT 1.4.3
addon: BiDi Mail UI 0.9.6
addon: WAT 1.3.1
addon: Hebrew spell-checking dictionary (from HSpell) 1.1.0.1
addon: Tiny Menu 2.0.4
addon: Maximize Message Pane 1.1.12
addon: Muttator 1.0
addon: Right Encoding 0.2.5
addon: Global Menu Bar integration 1.0.7
addon: New Mail Attention 1.2.1
addon: Quicktext 0.9.11.2
addon: Tag Toolbar 0.8.35
addon: Enigmail 1.3.2
addon: Virtual Identity 0.9pre2
addon: Thunderbird Conversations 2.1rc
addon: Silvermel 1.4.3 [DISABLED]
addon: Charamel 1.4.3 [DISABLED]
addon: Hebrew (IL) Language Pack 3.1.309 [DISABLED]
addon: Default 6.0
addon: English (GB) Language Pack 7.0 [DISABLED]
addon: Adobe Reader 9.4 
addon: IcedTea-Web Plugin (using IcedTea-Web 1.1.1 (1.1.1-0ubuntu1~11.04.1))  [DISABLED]
addon: Google Talk Plugin  [DISABLED]
addon: Google Talk Plugin Video Accelerator  [DISABLED]
addon: Skype Buttons for Kopete  [DISABLED]
addon: Shockwave Flash  [DISABLED]## rdfDatasource init: read rdf from 'file:///home/dotancohen/.thunderbird/d9r4cfa6.default/virtualIdentity.rdf'
## rdfDatasource: register AccountManagerObserver
## smartIdentity: Reply()
## smartIdentity: checking  against id5
## __getDescriptionAndType: 'Ido Cohen <ido.coh@--.com>' is no MailList
## rdfDatasource: readVIdentityFromRDF found stored data.
## rdfDatasource: email='ido.coh@--.com' fullName='Dotan Cohen' id='null' smtp='vI_useDefaultSMTP'
## rdfDatasource: extras: not used
## identityCollection:   add new address to result: Dotan Cohen <ido.coh@--.com>
## __getDescriptionAndType: 'Ido Cohen <ido.coh@--.com>' is no MailList
## rdfDatasource: findMatchingFilter for Ido Cohen <ido.coh@--.com>.
## rdfDatasource: findMatchingFilter no match found.
## storage: found 1 address(es)
## smartIdentity: SmartReply skipped, Identities in Storage found.
## smartIdentity: merged SmartReply & Storage, 1 address(es) left
## identityData: isExistingIdentity: ignoreFullNameWhileComparing='false'
## identityData: isExistingIdentity: Dotan Cohen <ido.coh@--.com> not found
## identityData: isExistingIdentity: ignoreFullNameWhileComparing='false'
## identityData: isExistingIdentity: Dotan Cohen <ido.coh@--.com> not found

## prepareSendMsg 0 0
## rdfDatasource init: read rdf from 'file:///home/dotancohen/.thunderbird/d9r4cfa6.default/virtualIdentity.rdf'
## rdfDatasource: register AccountManagerObserver
## rdfDatasource: storeVIdentityToAllRecipients dontUpdateMultipleNoEqual='false'
## rdfDatasource: __updateStorageFromVIdentity.
## __getDescriptionAndType: 'Ido Cohen <ido.coh@--.com>' is no MailList
## rdfDatasource: readVIdentityFromRDF found stored data.
## rdfDatasource: email='ido.coh@--.com' fullName='Dotan Cohen' id='null' smtp='vI_useDefaultSMTP'
## rdfDatasource: extras: not used
## __getDescriptionAndType: 'Ido Cohen <ido.coh@--.com>' is no MailList
## rdfDatasource: findMatchingFilter for Ido Cohen <ido.coh@--.com>.
## rdfDatasource: findMatchingFilter no match found.
## __getDescriptionAndType: 'Ido Cohen <ido.coh@--.com>' is no MailList

comment:16 Changed 8 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi,

required code-change is now part of conversation ( https://github.com/protz/GMail-Conversation-View/pull/498 ). Checkout latest conversation plugin for tests with virtual_identity-0.9pre3-tb+sm.xpi. A lot of code-changes happend since 0.9pre2, so please re-test and re-open the ticket if it is still not working.

You can use the current development-snapshot of conversation for testing.

Nice regards, Rene

Note: See TracTickets for help on using tickets.