Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#345 closed defect (fixed)

Cannot send mail

Reported by: Dotan Cohen <absorb.it@…> Owned by:
Version: 0.8.0 Keywords:
Cc:

Description

With 0 extensions, addons, or themes installed enabled for Virtual Identity 0.8.1 on Thunderbird 6.0, I cannot send mail. Pressing Ctrl-Enter does nothing, neither does pressing the Send button on the toolbar.

Change History (5)

comment:1 Changed 8 years ago by Dotan Cohen <absorb.it@…>

I found this in the error console: """ Error: An error occurred executing the cmd_sendWithCheck command: [Exception... "'Error: "vI.account.account is undefined" {file: "chrome://v_identity/content/v_identity.js" line: 336}?' when calling method: [nsIController::doCommand]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 96" data: yes] Source File: chrome://global/content/globalOverlay.js Line: 100 """

comment:2 Changed 8 years ago by Dotan Cohen <absorb.it@…>

I cannot find the file specified:

$ sudo updatedb $ locate v_identity.js $

comment:3 Changed 8 years ago by anonymous

sorry, will be fixed soon, blocked 0.8.1

comment:4 Changed 8 years ago by rene

Resolution: fixed
Status: newclosed

found the problem and fixed with [d14253a16f], released update as 0.8.2

Hope that this is the last problem, the fixes required to reduce namespace pollution had been bigger than what I liked. And for the next months I'm bound to webmail, so can'T practicaly check the addon on my own.

Thanks for the quick report, nice regards, Rene

comment:5 Changed 8 years ago by Dotan Cohen <absorb.it@…>

Thank you, I can confirm that the issue is fixed when not using any other addons.

Note: See TracTickets for help on using tickets.