Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#356 closed defect (wontfix)

VI no longer compatible with Postbox

Reported by: jay@… Owned by:
Version: 0.8.6 Keywords:
Cc:

Description

I'm running Postbox 2.5.3, VI 0.5.12. I'm having some trouble getting VI to detect a new domain I started using, so I first thought I'd update, but when I install 0.8.6, it says it's not compatible with Postbox 2.5.3.

Could this be a side effect of dropping old TB support? Postbox should be based on TB 3.1, but perhaps you're mis-detecting it?

Change History (10)

comment:1 Changed 8 years ago by anonymous

Yes, I just switched from TB 7 to Postbox and was very disappointed to see PB uses such an old version of VI. I'd love to see 0.8.6 updated to support PB 2.5! Please?

comment:2 Changed 8 years ago by rene

Resolution: wontfix
Status: newclosed

Hi Jay,

don't be disappointed - version 0.7 is exactly the right one you are using. And you won't get any new features using the 0.8-line... I just started a new branch to drop all the compatibility issues once and for a while. If you require any feature, I will check if this fit's into my ideas and timeframe and implement it for 0.8.x, but also for 0.7.x if you ask for it. Therefore 0.7 is in no aspect older than 0.8. 0.8 only has a different and cleaner code-base, which is nice for me...

Nice regards, Rene

Last edited 8 years ago by rene (previous) (diff)

comment:3 Changed 8 years ago by jay@…

Rene,

Thanks for the info; I didn't realize you were still supporting 0.7.x ☺ I just tried installing 0.7.3, and got the same error - Postbox 2.5.3 is not compatible. Any idea why?

comment:4 Changed 8 years ago by rene

Hi Jay,

it's not tagged as compatible, because I can't and won't test it with Postbox. As long as it is based on mozilla's code, it should practically work, but can't say. Therefore the contained compatibility information says nothing about postbox - and postbox says it's not compatible. Use some tool to override compatibility (for instance 'nightly tester tools') or change the index.rdf

Nice regards, Rene

comment:5 Changed 8 years ago by jay@…

No luck... when I install 0.7.3 with the changed rdf, it gets very screwy; the preferences panel is just "OK/cancel", and the data settings editor gives an XML parsing error.

Would you consider Postbox support if I bought you a license? Or do you still support 0.5.12 enough to help me fix my bug?

comment:6 Changed 8 years ago by kurdy

I really love VI too. Could we persuade you (financially) to make it work with Postbox V3.0.1?

comment:7 Changed 8 years ago by anonymous

Hi,

sorry, but I don't have the time to test the extension with postbox, therefore I can't help you in this case. If any postbox-user/developer like to adapt the extension, they are free to do so - the extension is free software anyway. But for me it's too much to support any spin-off from thunderbird, others are questioned to do this job...

Nice regards, Rene

comment:8 Changed 8 years ago by rene

Hi,

as suggested I mirrored the virtual identity code on https://github.com/absorb-it/Virtual-Identity , it will be updated daily and I'm looking forward to include any code-updates/improvements

Thanks for the suggestion, nice regards, Rene

comment:9 Changed 8 years ago by rene

Hi,

probably the best way will be to start with https://github.com/absorb-it/Virtual-Identity/tree/ng_0.9 , because the scripts are splitted into different directories there - it will be easier to read the code. And this will be the future version, but anyway, you can also start with ng_0.8 which is the current stable. Please don't go back to ng_0.6, this is just for compatibility issues with old seamonkey/thunderbird.

And, you can find information on how to build the extension in the wiki.

Nice regards, Rene

comment:10 Changed 7 years ago by anonymous

Hi Rene,

in light of the recent announcements on the future of Thunderbird, any chance you might change your mind and support Postbox? :-)

Note: See TracTickets for help on using tickets.