Opened 7 years ago

Closed 7 years ago

#392 closed defect (invalid)

Icons to switch save modes are gone

Reported by: anonymous Owned by: rene
Version: 0.9.0 Keywords:
Cc:

Description

Virtual Identity used to display a little circle icon in the statusbarpanel of the mail compose window that could be used to switch modes (save virtual IDs, save virtual IDs and SMTP,...).

This is no more there in version 0.9.0. Was this dumped intentionally or is this a bug?

Attachments (1)

check_and_send-0.9.24_mod-tb.xpi (44.5 KB) - added by rene 7 years ago.
modified check and send

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by rene

Hi,

this works for me with TB14, can you please provide some additional information...

Is there any other (colliding) extension activated?

Which Platform you are using (Windows, Mac, Linux) and which version of Thunderbird?

After opening the mail-compose window, are there any error messages related to virtual id in the Error log (main 3pane-window, Tools Menu)?

Thanks for your help to improve the extension, nice regards, Rene

comment:2 Changed 7 years ago by anonymous

Hi,

thanks, I researched and found that in fact it collides with the extension Check and Send (https://addons.mozilla.org/de/thunderbird/addon/check-and-send/). When this extension is disabled the Virtual Identity Icon appears.

I have no idea why, Check and Send is installed for ages in my Thunderbird and worked fine with previous Virtual Identity versions.

comment:3 Changed 7 years ago by anonymous

I investigated again and found that it's not "Check and Send" alone that causes this. I found three other extensions that also break Virtual Identity's icon ("Address Widget Lines", "Automatic dictionary", "Mail tweak"). I also used to have them installed for a longer time, so it's probably VI that has changed.

comment:4 Changed 7 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

thanks for the report, I will check this issue and fix it if possible.

Nice regards, Rene

Changed 7 years ago by rene

modified check and send

comment:5 Changed 7 years ago by rene

Resolution: invalid
Status: assignedclosed

Hi,

the problem is really one of the extension(s?). Tested with "Check and Send" and even the enigmail icons are gone. The problem is, that the extension accesses the Interface before it is completely created and destroys it that way. A quick fix (without further checking) can be found in the attachment above, implemented with the patch below:

--- chksend_old.js	2012-08-27 17:29:06.886973054 +0200
+++ chksend.js	2012-08-27 17:29:03.846968599 +0200
@@ -18,6 +18,7 @@
 var CASSetupper = {
 	initCAS: function() {
 		if (gMsgCompose) gMsgCompose.RegisterStateListener(CASStateListener);
+        document.getElementById("msgcomposeWindow").addEventListener("compose-window-reopen", CASSetupper.initCAS, false);
 	},
 	
 	finalizeCAS: function() {
@@ -28,7 +29,6 @@
 	}
 }
 window.addEventListener("load", CASSetupper.initCAS, false);
-document.getElementById("msgcomposeWindow").addEventListener("compose-window-reopen", CASSetupper.initCAS, false);
 window.addEventListener("close", CASSetupper.finalizeCAS, false);
 
 //Override original functions

Closing the ticket now, nice regards and thanks for the report, Rene

Note: See TracTickets for help on using tickets.