Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#394 closed defect (fixed)

Thunderbird Send button not working

Reported by: sullybeck@… Owned by: rene
Version: 0.9.2 Keywords:
Cc:

Description

In the past couple weeks, I've started having problems with thunderbird. After starting Thunderbird, for a while everything is fine. I'm able to send messages without a problem. But after a while (and I do ot know what triggers the problem, but it's usually some hours after a restart), the Send button in the compose window suddenly stops working. I compose a message and click on Send and nothing happens (i.e. the compose window remains active... I can continue to edit, but I cannot send). Restarting Thunderbird temporarily clears the problem and I can send mail.

I wasn't sure when I last updated Thunderbird (initially, I was running version 14), so I downgraded to 12 (which definitely predates the problem) and no luck. I haven't yet re-upgraded, so I'm still at 12 in case that turns out to be important.

In the error console, I get the message:

Error: An error occurred executing the cmd_sendButton command: [Exception... "'Error: "currentWindow.document is null" {file: "resource://v_identity/vI_replyToSelf.js" line: 55}?' when calling method: [nsIController::doCommand]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 96" data: yes] Source File: chrome://global/content/globalOverlay.js Line: 100

I turned off all of the extensions and ran for a day with no problems. Then I reenabled them one at a time and ran for a day. Today, it stopped working after reenabling Virtual Identity. In the past few weeks, I've upgraded both java (from JRE 1.7.0u5 to 1.7.0u6) and Virtual Identity (from 0.8.9 to 0.9.2). Not sure which specifically is responsible for the problem... I will continue to test and figure out, but I figure you'd want to make sure that virtual identity worked with the newest java.

I'll update this ticket as I find out anything new, but since each test can take a day, it'll be a bit slow.

Change History (16)

comment:1 Changed 7 years ago by anonymous

Yesterday, I downgraded Virtual Identity to 0.8.9 and have now been running for a day with no problems. I'll update the ticket again if that changes.

  • sullybeck

comment:2 Changed 7 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

thanks for the precise report, I will check this issue and hopefully fix it the next days.

Nice regards, Rene

comment:3 Changed 7 years ago by add-on-it.de@…

confirm this error with TB 14.0 and v0.9.2:

Fehler: An error occurred executing the cmd_sendWithCheck command: [Exception... "'[JavaScript Error: "top is null" {file: "chrome://messenger/content/messengercompose/addressingWidgetOverlay.js" line: 322}]' when calling method: [nsIController::doCommand]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 96"  data: yes]
Quelldatei: chrome://global/content/globalOverlay.js
Zeile: 100

comment:4 Changed 7 years ago by rene

Hi,

maybe this is a more general issue? See http://forums.mozillazine.org/viewtopic.php?f=29&t=2480423&p=12233699#p12233699

I still can't reproduce the problem and if I checkthe addressingWidgeOverlay of Thunderbird14, there is no top-reference in line 322. Strange thing...

Looking forward for any idea how to trace this issue, Nice regards, Rene

comment:5 Changed 7 years ago by S. Beck <sullybeck@…>

The bug very well could be in Thunderbird instead of Virtual Identity... but I'm 95% certain that Virtual Identity is doing something that triggers the bug.

The problem was occurring typically within 2-4 hours of restarting Thunderbird (so I was forced to restart Thunderbird 1-3 times per day), and since I have downgraded Virtual Identity 5 days ago, it has not happened a single time.

BTW, I just re-upgraded Thunderbird to 14.0 (still running VI 0.8.9) and if it stops working, I'll update the ticket.

comment:6 Changed 7 years ago by S. Beck <sullybeck@…>

Here's some more info.

I ran TB 14 / VI 0.8.9 for more than a day with no problems.

I decided to do some more testing and upgraded VI to 0.9.2 . This morning, it's broken again. I tested some of the other buttons (Attach, Security, Save, etc.) and they seem to work fine.

I tried sending using the keyboard shortcut (Ctrl-Enter). I hit the shortcut and the confirmation box pops up. The Cancel button works (the pop up disappears) but the Send button doesn't work. The pop up disappears, but the compose window stays up and the mail is not sent.

Other buttons in Thunderbird work (I can compose another message for example... but it won't send either).

I'm going to downgrade to 0.8.9 again since I need a working thunderbird, but if there's any other testing I can do, let me know.

comment:7 Changed 7 years ago by rene

Hi,

released 0.9.3 which should fix the initial error on this ticket

[Exception... "'Error: "currentWindow.document is null" {file: "resource://v_identity/vI_replyToSelf.js" line: 55}?' when calling method: [nsIController::doCommand]" nsresult: "0x80570021

it's worth to check if this also fixes the issue with broken sending, but still have no idea how to reproduce the issue here. Leave the ticket open,

regards, Rene

comment:8 Changed 7 years ago by S. Beck <sullybeck@…>

I just installed 0.9.3... I'll let you know if it works...

comment:9 Changed 7 years ago by S. Beck <sullybeck@…>

I've been running for almost a day, and it is still working, so it appears that 0.9.3 fixed the problem (or at the very least, it avoids the bug).

If that changes, I'll let you know of course! :-)

comment:10 Changed 7 years ago by rene

Hi,

hope this keeps as good as it sounds... leaving the ticket open for new, currently not trusting the peace :)

Nice regards, Rene

comment:11 Changed 7 years ago by anonymous

I've been communicating with Rene offline re: this same issue; moving the discussion here, per request.

After upgrading to TB15/linux64 + VI 0.9.3 the inability to send after 1st attempt appears to have been cured. In a few tests, I'm able to send, re-send, create new identities, etc.

I've verified that the data store *is* successfully / correctly updated on new VI creation.

However, when composing a message, whether creating a new virtual identity OR using an existing one, the "Reply-to" is NOT being set to the VI even though:

"Set virtual identity as Reply-to address"

*IS* checked in the prefs.

Richard

comment:12 Changed 7 years ago by rene

Hi Richard,

great to hear that the major problem seams to be solved - hope that it stays like this. The "reply-to"-issue is not really fixed by now, ok. But I currently prevented the "reply-to"-feature to be a real showstopper - not nice but works for now. Hope to fix this soon,

Thanks for your patience, Regards, Rene

comment:13 Changed 7 years ago by S. Beck <sullybeck@…>

I've had a new problem pop up which may be related...

Again, after a restart of TB, everything works fine for a while (which is why I think they may be related somehow). Then, after a period (but this one seems longer... more like in the next 36 hours or so) the problem occurs. When I compose a new message, the "To" menu (and the address field) is grayed out so I cannot specify a recipient. If I reply to a message, the compose message window comes up but the recipient is blank and grayed out so I can't reply.

I was running TB 15.0 and VI 0.9.3 and it happened twice. After the first, I did a full update to make sure I was fully patched and then rebooted, and after about a day, it happened again.

I've now downgraded back to VI 0.8.9 to see if it happens again (still running TB 15.0).

I'll try to get more information... I just wanted to update in case anyone else is seeing this.

comment:14 Changed 7 years ago by S. Beck <sullybeck@…>

After 4 days of running 0.8.9 without problem, I switched back to 0.9.3. Now, a day later, the problem has recurred. There are a few errors in the console that may (or may not) be related:

Error: TypeError?: vIcomposeWindow.top is null Source File: resource://v_identity/vI_replyToSelf.js Line: 43

Error: TypeError?: awSetInputAndPopupValues is not a function Source File: chrome://messenger/content/messengercompose/addressing/WidgetOverlay.js Line: 251

Interestingly (though probably not important), the To line is now coming up greyed out but it contains the email address of the last person I mailed (regardless of whether I'm composing a new message, or replying to an existing one).

I'm going to downgrade back to 0.8.9... let me know if there's any additional information/testing I can provide and I'll be happy to look into this further.

comment:15 Changed 7 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi,

thanks for the report, I think I finally found the issue. Opening multiple windows with virtual identity triggered these problems with the reply-to feature. Which in the end caused the termination of the sending process. This problem is fixed with [4e1f8f79cb98d66d21d6]. There are probably side-effects to other features of virtual identity too - I will check this in the following weeks.

Closing this ticket now (in the hope that this problem is fixed :) ), but please reopen if it still reoccurs. Thanks again for all the reports and the patience,

nice regards, Rene

comment:16 Changed 7 years ago by S. Beck <sullybeck@…>

Just wanted to check in... I've been running TB 15.0 / VI 0.9.4 for a week now with no problems, so I agree that it appears that the problem is fixed.

Thanks!

Note: See TracTickets for help on using tickets.