Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#395 closed defect (fixed)

"You already have..." dialog showing identical given/stored identities, ignoring "Use Stored Identity"

Reported by: mozkeith2@… Owned by: rene
Version: 0.9.3 Keywords:
Cc:

Description

Since 0.9.0 or 0.9.1 (not sure which), I've been running into many cases where I go to send an email, and am prompted with the "You already have a virtual identity for the recipient" dialog. However, the given identity and stored identity are completely the same.

When this happens, I usually choose "Use stored identity", but then it returns to the email and doesn't send it. It only sends it if I choose "OK", even though nothing changes. I did check, and it does NOT create duplicate entries in the database, so it seems to be nothing more than a minor nuisance.

Attachments (1)

Log20121119.txt (30.9 KB) - added by anonymous 7 years ago.
Log with version 0.9.5-1-g6f8488c

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by mozkeith2@…

Two additional comments.

First, this change also may have come about with Thunderbird 15, and not an update to VirtualIdentity?. I haven't been able to confirm this, since I don't have the same database on other machines.

Second, this may or may not be related, but I'm also having problems where the identity (and signature) is no longer automatically changing when I put in a recipient's address that only has one stored virtual identity.

I suspect it is related, as both problems could be the result of a corrupted VI data store. I certainly HOPE that's not the case, but it's a viable explanation, one that I hope log files (which I'll try to provide the next time it happens) might help prove or disprove.

comment:2 Changed 7 years ago by Keith S. <mozkeith2@…>

One more quick update -- the second issue goes away if I exit and restart Thunderbird. Whereas the first one does not. So it's probably not related. I'll log a separate bug when I can get more information on making it reproduce.

comment:3 Changed 7 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

if you use "Use stored identity" the identity will be replaced with the stored one, but not sended immediately, this is the idea. The interface is a little disturbing, it's all about "storing the new identity" and asks for "ok" or "cancel". So, if you press cancel, the mail will be sent without storing the new identity.

Regarding the real bug, do you have any extra features stored in you identity database? These might trigger the problem, but can't proove this now. A debug-log will be nice :)

Regards, Thanks for the report, Rene

comment:4 Changed 7 years ago by anonymous

I am also having the problem of redundant prompting. Now running 0.9.5 on Tb 16.0.1 and still the same issue.

The prompt shows almost the same identity in the left and right column (left column has a "struck out" SMTP server, right column has no SMTP server). Selecting "OK" to store the "changed" identity has no effect on the next attempt to send mail to the same recipient, looking in the editor, the identity now has today's creation and last use date, and still a blank SMTP. The "Store used SMTP" is unchecked in settings, which may be the trigger.

Here is the debug output for a test (I didn't send anything this time):

--------------------------------------------------------------------------------
Thunderbird 16.0.1 (20121010150919; Windows NT 5.2; WOW64)
--------------------------------------------------------------------------------
main: mod. FillIdentityList
main: init.
main: adapt GenericSendMessage
main: initSystemStage1.
virtualIdentity:  v_identity.xml identityData setter
virtualIdentity:  v_identity.xml smtp set to 'smtp1'
virtualIdentity:  v_identity.xml resultingID: fullName='Tester' email='maila@example.com' smtp='smtp1' id='id8' existingID='true'
virtualIdentity:  v_identity.xml identityData setter done.
main: initSystemStage1 done.
main: init done.
main: NotifyComposeFieldsReady
main: NotifyComposeBodyReady
main: initSystemStage2.
rdfDatasource:  init: read rdf from 'file:///C:/Documents%20and%20Settings/jb/Application%20Data/Thunderbird/Profiles/5vnm2bte.default/virtualIdentity.rdf'
rdfDatasource:  register AccountManagerObserver
smartIdentity:  msgComposeTypeReference = 6
smartIdentity:  Reply
rdfDatasource:  init: read rdf from 'file:///C:/Documents%20and%20Settings/jb/Application%20Data/Thunderbird/Profiles/5vnm2bte.default/virtualIdentity.rdf'
rdfDatasource:  register AccountManagerObserver
smartIdentityCollection:  Reply()
smartIdentityCollection:  checking  :id3:  :id4:  :id5:  :id1:  :id6:  :id7:  :id9:  against id8
rdfDatasource:  __getDescriptionAndType: 'mailb@example.com' is no MailList
rdfDatasource:  readVIdentityFromRDF found stored data.
rdfDatasource:  email='maila@example.com' fullName='Tester' id='id8' smtp='vI_noStoredSMTP'
identityData: add new address to result: Tester <maila@example.com>
rdfDatasource:  __getDescriptionAndType: 'mailb@example.com' is no MailList
rdfDatasource:  findMatchingFilter for mailb@example.com
rdfDatasource:  findMatchingFilter no match found.
rdfDatasource:  found 1 address(es)
smartIdentityCollection:  SmartReply skipped, Identities in Storage found.
identityData: add new address to result: Tester <maila@example.com>
smartIdentityCollection:  merged SmartReply & Storage, 1 address(es) left
smartIdentity:  __smartIdentitySelection autocreate=false
identityData: isExistingIdentity: ignoreFullNameWhileComparing='false'
identityData: isExistingIdentity: Tester <maila@example.com> found, id='id8'
smartIdentityCollection:  found existing Identity, reorder to prefer this one.
smartIdentity:  found existing Identity, use without interaction.
smartIdentity:  changeIdentityToSmartIdentity selectedValue=0 from 1
smartIdentity:  changeIdentityToSmartIdentity selectedValue=0: 'Tester <maila@example.com>' (Tester <maila@example.com>,)
virtualIdentity:  v_identity.xml msgIdentityCloneElem.doCommand()
virtualIdentity:  v_identity.xml copy selected Menu-Value from clone to orig. Searching for id=id8
virtualIdentity:  v_identity.xml identityData setter
virtualIdentity:  v_identity.xml previousID: fullName='Tester' email='maila@example.com' smtp='smtp1' id='id8' existingID='true'
virtualIdentity:  v_identity.xml newID: fullName='Tester' email='maila@example.com' smtp='smtp1' id='id8' existingID='true'
virtualIdentity:  v_identity.xml smtp set to 'smtp1'
virtualIdentity:  v_identity.xml resultingID: fullName='Tester' email='maila@example.com' smtp='smtp1' id='id8' existingID='true'
virtualIdentity:  v_identity.xml identityData setter done.
virtualIdentity:  v_identity.xml msgIdentityCloneElem.doCommand() this.value=id8
main: initSystemStage2 done.
--------------------------------------------------------------------------------
addon: Dansk ordbog til stavekontrollen 2.2.1
addon: Imap-ACL-Extension 0.2.2
addon: Test Pilot for Thunderbird 1.3.9 [DISABLED]
addon: Console² 0.9
addon: Allow HTML Temp 3.6.2
addon: Folder Account 5.0
addon: Toggle Word Wrap 1.9
addon: .vcs Support 0.6.4
addon: Default 16.0.1
addon: Lightning 1.8
addon: Calendar Tweaks 4.2
addon: Virtual Identity 0.9.5
addon: Stationery 0.7.8
addon: Year View 0.4.1
addon: QuickTime Plug-in 7.7.2 7.7.2.0 [DISABLED]
addon: Shockwave Flash 11.4.402.278 [DISABLED]
addon: Java(TM) Platform SE 6 U35 6.0.350.10 [DISABLED]
addon: Java Deployment Toolkit 6.0.350.10 6.0.350.10 [DISABLED]
addon: Foxit Reader Plugin for Mozilla 2.2.1.530 [DISABLED]
addon: Windows Presentation Foundation 3.5.30729.1 [DISABLED]
addon: 2007 Microsoft Office system 12.0.4518.1014 [DISABLED]
--------------------------------------------------------------------------------
main: VIdentity_GenericSendMessage
main: VIdentity_GenericSendMessage top=[object ChromeWindow]
account:  prepareSendMsg 0 0
rdfDatasource:  init: read rdf from 'file:///C:/Documents%20and%20Settings/jb/Application%20Data/Thunderbird/Profiles/5vnm2bte.default/virtualIdentity.rdf'
rdfDatasource:  register AccountManagerObserver
rdfDatasource:  storeVIdentityToAllRecipients dontUpdateMultipleNoEqual='false'
rdfDatasource:  __updateStorageFromVIdentity.
rdfDatasource:  __getDescriptionAndType: 'mailb@example.com' is no MailList
rdfDatasource:  readVIdentityFromRDF found stored data.
rdfDatasource:  email='maila@example.com' fullName='Tester' id='id8' smtp='vI_noStoredSMTP'
rdfDatasource:  __getDescriptionAndType: 'mailb@example.com' is no MailList
rdfDatasource:  findMatchingFilter for mailb@example.com
rdfDatasource:  findMatchingFilter no match found.
rdfDatasource:  __updateStorageFromVIdentity updating
rdfDatasource:  __updateStorageFromVIdentity overwrite warning
rdfDatasource:  retVar.returnValue=abort
account:  prepareSendMsg: sending aborted
main: sending: --------------  aborted  ---------------------------------
Last edited 7 years ago by rene (previous) (diff)

comment:5 Changed 7 years ago by rene

Hi,

I uploaded some intermediate release with some additional debugging, please use this version to provide any more precise debug-log. See: http://absorb.it/software/virtual_identity/other/virtual_identity-0.9.5-1-g6f8488c-tb+sm.xpi

Before posting, please check for confidential information in the log :9

Regards, Rene

Changed 7 years ago by anonymous

Attachment: Log20121119.txt added

Log with version 0.9.5-1-g6f8488c

comment:6 Changed 7 years ago by mozkeith2@…

Just a quick note -- apologize for not responding earlier; I must have changed my notifications to not get an email when a ticket I created was updated, so I didn't see the response.

I'm still seeing these issues in 17.0, and I tried removing my entire database to see if it had anything to do with corrupt data. It didn't. With a completely empty database, I created an email to someone, then when I replied to that person's response, I had the same prompt to either use my identity or the stored one -- even though they were identical.

I was about to collect some debugging information for you, but will switch to using your intermediate release instead and will do that now.

comment:7 Changed 7 years ago by anonymous

Also, FWIW -- there may be an issue (or a misunderstanding on my part) with the SmartReply? filter, so maybe you can confirm whether or not this is in any way related.

I have several email accounts. Let's say one is @foo.com, and the other is @bar.com. I have a SmartReply? filter for /@bar.com$/. Doesn't that mean that VI shouldn't try to propose alternate identities when replying to email sent to @foo.com? (Because it is.)

If this is an issue, and likely not related, I'll log a separate ticket. But since this change in behavior started happening at the same time as the redundant prompts mentioned above, I figured I'd check first.

comment:8 in reply to:  7 Changed 7 years ago by mozkeith2@…

Replying to anonymous: (Sorry, that was the same user.)

comment:9 Changed 7 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi,

there had been some errors in the usage of extra-storage-items. They had not been ignored while comparing the final identities and those differences were not shown in the interface.

Fixed this with [8aa4c2513621c], this is released as 0.9.7

Thanks for your reports, without them I would never have found anything,

Regards, Rene

(closing this ticket, please reopen if problem is not fixed)

comment:10 Changed 7 years ago by mozkeith2@…

Great - thanks, Rene! Sorry I wasn't able to get you more useful information sooner. Next time!

Note: See TracTickets for help on using tickets.