Opened 7 years ago

Closed 7 years ago

#400 closed defect (fixed)

VirtualIdentity stopped working properly

Reported by: hunter_six@… Owned by: rene
Version: 0.9.4 Keywords:
Cc:

Description

I use VirtualIdentity? 0.9.5 and Thunderbird 15.0.1 on Ubuntu. For some reason, VirtualIdentity? does not select a virtual identity any more when replying to email, nor does it switch to other identities when composing new mail to existing contacts.

I can still edit sender.

Change History (7)

comment:1 Changed 7 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

recently switched to TB15 here and can't see any issues with that. Can you please provide some debug-logs, check FAQ for information how to do this. It will be nice to see some debug-log once you select the mail you are going to "reply-to", and the one which can be seen in the Compose-Dialog too. Please check the Javascript-Error-Console for related errors too (see Tools Menu).

Hope to get this issue fixed soon, nice regards, Rene

comment:2 Changed 7 years ago by hunter_six@…

Sorry for the trouble. :(

selecting mail:

getHeader:	found header: received  ...stored to recognize received mail
getHeader:	found header: to - stored as 'alias@example.com'
GetHeaderNotification:	to:	alias@example.com

composing reply to:

main:	composeDialog reopened. (msgType 6)
virtualIdentity:	v_identity.xml identityData setter
virtualIdentity:	v_identity.xml identityData setter done.
main:	everything cleaned.
main:	initSystemStage1.
virtualIdentity:	v_identity.xml identityData setter
virtualIdentity:	v_identity.xml smtp set to 'smtp1'
virtualIdentity:	v_identity.xml resultingID: fullName='My Full Name' email='original@example.com' smtp='smtp1' id='id1' existingID='true'
virtualIdentity:	v_identity.xml identityData setter done.

comment:3 Changed 7 years ago by rene

Hi,

the requested Identity is detected in the main window, and usually the most interesting part of the composeDialog comes directly after your messages... something like

main:	initSystemStage1 done.
main:	reopen done.
main:	NotifyComposeFieldsReady
main:	NotifyComposeBodyReady
main:	initSystemStage2.

Can you please check the Error-Console for any related Errors after opening the Message-Compose-Window?

Thanks, nice regards, Rene

comment:4 Changed 7 years ago by anonymous

When I select a mail, the following error appears in the Javascript error console multiple times:

Timestamp: 22.10.2012 11:56:04
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.getStringProperty]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/folderPane.js :: getSmartFolderName :: line 2436"  data: no]
Source File: chrome://messenger/content/folderPane.js
Line: 2438

When I click reply, the same error repeats a few times, plus:

Timestamp: 22.10.2012 11:59:18
Error: ReferenceError: awGetInputElement is not defined
Source File: chrome://v_identity/content/vI_storage.js
Line: 102

Excerpt from folderPane.js around line 2438:

function getSmartFolderName(aFolder) {
  try {
    return aFolder.getStringProperty("smartFolderName");
  } catch (ex) {
    Components.utils.reportError(ex);
    return null;
  }
}

comment:5 Changed 7 years ago by rene

Hi,

Timestamp: 22.10.2012 11:59:18
Error: ReferenceError: awGetInputElement is not defined
Source File: chrome://v_identity/content/vI_storage.js
Line: 102

this is the critical issue. Can't reproduce this here, but created some patched release, which probably fixes your issue. Check with virtual_identity-0.9.5-2-ge55f925-tb+sm.xpi. Do you have any extensions in use, which might trigger this behavior?

Nice regards, Rene

comment:6 Changed 7 years ago by anonymous

Wow, thanks, it seems to work with your fix!

--------------------------------------------------------------------------------
addon: Quick Locale Switcher 1.7.8
addon: Mail Merge 3.4.0
addon: Enigmail 1.4.4
addon: EDS Contact Integration 0.3.11
addon: Default 15.0.1
addon: Messaging Menu and Unity Launcher integration 0.9.3
addon: Global Menu Bar integration 3.4.2
addon: Deutsch (DE) Language Pack 15.0.1
addon: English (GB) Language Pack 15.0.1
addon: Virtual Identity 0.9.5
addon: Shockwave Flash 
addon: iTunes Application Detector 
addon: Windows Media Player Plug-in 10 (compatible; Totem) 
addon: VLC Multimedia Plugin (compatible Totem 3.0.1) 
addon: DivX® Web Player 
addon: QuickTime Plug-in 7.6.6 
addon: mplayerplug-in is now gecko-mediaplayer 1.0.4 
addon: Windows Media Player Plug-in 
addon: QuickTime Plug-in 7.6.9 
addon: DivX Browser Plug-In 
addon: RealPlayer 9 
--------------------------------------------------------------------------------

comment:7 Changed 7 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi,

thanks for you report, released 0.9.6 containing the fix.

Nice regards, Rene

Note: See TracTickets for help on using tickets.