Opened 8 years ago

Last modified 8 years ago

#403 new defect

Messages incorrectly identified as sent instead of received

Reported by: Callum Macdonald <absorb.it@…> Owned by:
Version: 0.9.9 Keywords:
Cc:

Description

My received email does have a "Received:" header, my sent mail does not. When I reply to a message, according to the debug output, the message is incorrectly being detected as a sent message, so SmartDraft? is being used.

If I disable the "All received mail contains a 'received' header", then messages in my inbox are correctly identified as incoming. However, from the debug output, I get:

smartIdentityCollection:	reading header 'x-envelope-to': ''
smartIdentityCollection:	reading header 'x-original-to': ''
smartIdentityCollection:	reading header 'to': ''
smartIdentityCollection:	reading header 'cc': ''
smartIdentityCollection:	0 address(es) after parsing, before filtering

There is an X-Envelope-To header and in this case also a To: header, both of which contain the address I want to use as a virtual identity. I've attached an example of the debug output in both cases (always the same message, always a received message).

Attachments (2)

virtualid_smartdraft.log (2.4 KB) - added by Callum Macdonald <absorb.it@…> 8 years ago.
Debug output when the message is (incorrectly) flagged as sent
virtualid_smartreply.log (3.0 KB) - added by Callum Macdonald <absorb.it@…> 8 years ago.
Debug output when the message is correctly flagged as received

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Callum Macdonald <absorb.it@…>

Attachment: virtualid_smartdraft.log added

Debug output when the message is (incorrectly) flagged as sent

Changed 8 years ago by Callum Macdonald <absorb.it@…>

Attachment: virtualid_smartreply.log added

Debug output when the message is correctly flagged as received

comment:1 Changed 8 years ago by rene

Hi,

thanks for the detailed report. The problem might occur before you select to reply to the mail, while reading/looking at the mail. This is the moment when the headers are read, usually while watching the email in the 3-pane preview window. Does the debug-log shows that there are headers detected when looking at the mail? Are there any errors in the Javascript Error Console (see Tools Menu)? Are you using the preview at all, how do you activate the reply?

Nice regards, Rene

comment:2 Changed 8 years ago by Callum Macdonald<absorb.it@…>

Apologies, I didn't notice your ticket reply. Does trac send emails by default?

Anyhoo, wonderful, you've hit the nail on the head. I am in the process of migrating from Evolution to Thunderbird (primarily to use this plugin!), and so I was replying to messages that I had never read in Thunderbird. I had the message pane (F8) disabled, and I had never opened the message in Thunderbird (I had opened it previously in Evolution or on my phone). The plugin works as expected if I open the message once, either in the message pane or its own tab. Apparently even if I open the message once, then quit Thunderbird, and restart, that's sufficient.

It appears that if a message has never been opened, the headers are never seen by virtual-id, but once the message has been opened, the headers are parsed and saved somewhere. Is that correct?

Maybe we can add something to the docs that mentions this? I'm guessing that this behaviour is not easily changed.

Note: See TracTickets for help on using tickets.