Opened 7 years ago

Closed 7 years ago

#405 closed defect (fixed)

VirtualIdentity "Status Message" styling is unreadable

Reported by: anonymous Owned by:
Version: 0.9.10 Keywords:
Cc:

Description

hi,

I've 0.9.9 installed in TB 17.0.3 on linux/64+KDE.

the styling of the VI StatusMessage? pane displays, currently, as dark-red text on a black background. It's completely unreadable ...

Afaict, there's no styling options in the UI (did I miss them?)

Nice to be able to specify the CSS in a UserStyle? script, or, at least, have the default be something more readable.

Attachments (1)

VI_CSS.png (20.5 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by rene

Hi,

is there any special theme you are using? I am using TB17.0.2 on KDE and don't have any problems with the default styling...

not sure what might be a good way out of this trouble (yes, recomposing the complete css, but thats too much)

regards, Rene

comment:2 Changed 7 years ago by anonymous

no, no special theme.

i have some UserStyles? defined, defining other elements elsewhere, but disabling them has no effect on the styling in VI.

comment:3 Changed 7 years ago by anonymous

just fyi, still an issue with v0.9.10

Changed 7 years ago by anonymous

Attachment: VI_CSS.png added

comment:4 Changed 7 years ago by anonymous

VI's 'sections' displayed in TBird remains unreadable: very dark red text on a black background.

cref the attachment for an image

Where can this styling be corrected?

comment:5 Changed 7 years ago by rene

Hi,

still can't reproduce your issue, but tried some fix without knowing whats really going on. Please try the changed version virtual_identity-0.9.10-1-g65386fb-tb+sm.xpi and report if this fixes your problems...

Nice regards, Rene

comment:6 Changed 7 years ago by anonymous

Hi,

That seems to have fixed the problem! CSS Styling of the VI pane is now same as the normal message header -- and once again completel readable.

Thanks!

comment:7 Changed 7 years ago by anonymous

Version: 0.9.90.9.10

hi,

could you perhaps push the version string of this patched xpi to be greater than the current @mozilla version string? the autoupdate feature of TBird keeps overwriting THIS, installed version with the 'broken' older version ...

just a temp-fix until a full/new release.

thanks.

comment:8 Changed 7 years ago by rene

Resolution: fixed
Status: newclosed

Hi,

thanks for the reminder, released the fix as 0.9.11.

Nice regards, Rene

Note: See TracTickets for help on using tickets.