Opened 7 years ago

Closed 7 years ago

#413 closed defect (wontfix)

Signature Being Stripped and/or Duplicated

Reported by: Brian <b_sleeth@…> Owned by:
Version: 0.9.13 Keywords: signature, duplicate, strip, remove, quote
Cc:

Description

Using Thunderbird 17.0.6 on Windows 7, I have an account with 3 identities. Each identity has its own Signature. I have set the Composition & Addressing options on the account as follows:

  • Compose messages in HTML format (checked)
  • Automatically quote the original message when replying (checked)
    • Then, "start my reply above the quote"
    • and place my signature "below the quote (recommended)"
  • Include signature for replies (checked)
  • Include signature for forwards (checked)

When I click reply/reply-all, the signature on the original email is stripped off, leaving two blank indented/quoted lines at the bottom of the email.

At this point, there are two different problems based (I think) on whether the Smart Reply selected the "From" identity or not.

  1. If the Smart Reply did NOT select the "From" identity, my cursor is placed at the top of the email and the selected identity's signature is placed at the bottom of the email as expected. In this case, so far, the only problem is that the original signature was stripped off of the reply.
  1. If the Smart Reply does select the "From" identity, the selected identity's signature is placed as part of the original email (it is indented with the vertical bars on the left). Additionally, the cursor is placed at the end of the signature (on the bottom of the email).

If I change the "From" identity (using the up/down arrow keys), in the first case (a), the current signature is correctly removed; however, the new signature is added to the original email (as in the case of b).

Once the signature gets added as-if it were part of the original email, each time I select a different identity, the new identity's signature is appended to the email. This causes the email to have my signature added multiple times to the email all of which appear as-if they were part of the original email.

Change History (7)

comment:1 Changed 7 years ago by Brian <b_sleeth@…>

NOTE: My work-around is to remove all signatures from my Thunderbird accounts/identities and then use the Signature Switch add-on.

I configured Signature Switch to be "off" by default. This requires me to manually select my various signatures. But, it is far better to send an email without a signature than with the wrong identity.

This work-around still leaves the problem of the original signature being stripped on my replies, but I think I can live with that for the time being.

BTW: Thank you for this great add-on!

comment:2 Changed 7 years ago by rene

Hi Brian,

thanks for your report. I will be (mostly) offline for the next month and not beeing able to check whats really going on with the signatures. Please remind me in July, if I'm missing to come back with a solution for this problem :)

Nice regards, and sorry for letting you waiting, Rene

comment:3 Changed 7 years ago by Brian <b_sleeth@…>

Rene,

No apology needed. I am just very thankful that you have shared this great add-on and continue developing it.

In fact, I think it is I who should apologize for the the very long bug report. I just found it hard to describe.

Again, thank you for this great tool. I will check back in mid-July.

Best Regards, Brian

comment:4 Changed 7 years ago by rene

Hi,

case a) the only problem is that the original signature was stripped off of the reply.

I think this is a feature of Thunderbird, this is probably not related to the extension

case b)

no answer yet, but

...however, the new signature is added to the original email (as in the case of b). Once the signature gets added as-if it were part of the original email, each time I select a different identity, the new identity's signature is appended to the email. This causes the email to have my signature added multiple times to the email all of which appear as-if they were part of the original email.

this happens even if I have the virtual-identity and the signature-switch-extension disabled if I just change between different Identities with signatures. Probably this is a bug in Thunderbird, have you checked if this is still a problem with current thunderbird versions (myself using 17.0.2)

Regards, sorry for not beeing really helpful till now,

Rene

comment:5 Changed 7 years ago by rene

Hi,

this happened to me if I composed messages in HTML, but some of the used signatures where 'not html'. After selecting some identity with a non-html-signature, the trouble started (no extension activated)

Regards, Rene

comment:6 Changed 7 years ago by Brian <b_sleeth@…>

This morning I figured I would retest to make sure I still had a problem. I could not reproduce the original problem nor could I get the signature to be stripped off.

NOTE: My current configuration was to have no signature on the accounts and to use the Signature Switch Add-On to select an HTML signature.

I just noticed your last reply and disabled both Signature Switch and Virtual Identity. I then added HTML signatures to all identities on an account and voilà ... duplicate signatures started to appear.

I could never get the signature to be stripped. Perhaps something was (silently) fixed in Thunderbird 17.0.7?!?

Thanks for all your work on Virtual Identity. Sorry I wasted your time chasing down a Thunderbird problem.

Regards, Brian

comment:7 Changed 7 years ago by anonymous

Resolution: wontfix
Status: newclosed

Hi,

thanks for the reply, I'm closing this ticket now. No problem with your report, it's always good if people report their problems - thats the only way to make the software better...

Nice regards, Rene

Note: See TracTickets for help on using tickets.