Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#51 closed defect (fixed)

breaks compose window in Thunderbird 3 alpha

Reported by: akaihola Owned by: rene
Version: 0.5.2 Keywords:
Cc:

Description

After installing Virtual Identity 0.5.2 in Thunberbird 3.0a1pre (2008042703) on Ubuntu 8.04, new messages can't be composed. Thunderbird displays a

Message Compose An error occurred while creating a message compose window. Please try again.

error dialog instead.

Change History (6)

comment:1 Changed 13 years ago by rene

Owner: set to rene
Status: newassigned

Thanks for the report, I will have a look at the problem as soon as possible (need some bandwidth to download TB3a)

Regards, Rene

comment:2 Changed 13 years ago by akaihola

I checked 0.5.0 and 0.5.1 just in case, and both have the same problem. Version 0.4.4 allows me to compose messages but doesn't provide the field for typing in the sender address.

I also found backups of previous Thunderbird nightlies I've used. The one for 2008-04-19 is broken with Virtual Identity 0.5.2, but 2008-03-11 seems to work correctly.

comment:3 Changed 13 years ago by anonymous

Hi,

debugging will take longer than expected. Current builds of TB-alpha (4th May 08) require gtk+ 2.10, ad I'm still using 2.8 here. Think I will setup a virtual machine to test it, but I need time and bandwidth (using gprs by now). So stay tuned,

Rene

comment:4 Changed 13 years ago by rene

Just checked with TBalpha and recognized that there had been a lot of changes in TBalpha compared to TB2.0. It's hard to trace them by trial and error, and I couldn't find a TBalpha API description till now (something like http://www.xulplanet.com/ ). Nether I found a changelog or something similar. So, if anybody can point me to some related sources...

Regards, Rene

comment:5 Changed 13 years ago by akaihola

Apparently the API is a moving target since I get so varying results with nightly builds from the past two months.

For curiosity I tried with the 2008-03-31 build, and I get no error when opening the compose window, but the virtual identity functionality is not enabled for the "From" field.

So something definitely changed between 2008-03-11 and 2008-03-31.

comment:6 Changed 13 years ago by rene

Resolution: fixed
Status: assignedclosed

made sixth pre-release (check download-Page) compatible with TB till 3a2pre (2008051703). Testing required. Thanks for reporting, please reopen and report if there are any further problems.

Regards, Rene

Note: See TracTickets for help on using tickets.