Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#78 closed defect (fixed)

reply does not work in 0.5.5 for TB3a1

Reported by: vi@… Owned by: rene
Version: 0.5.5 Keywords:
Cc:

Description

In 0.5.5: if I reply to a mail, always the default sender is used. Activatiting the debug window, I see that everything is done perfect: the correct address is selected from "To:", the correct address is picked from storage (both are the same), then addresses are filtered and the address left is jms2friend1@…. But then, in the "from:" field in the reply is "jms@…" I went back to 0.5.4 and it is ok!

Change History (8)

comment:1 Changed 12 years ago by vi@…

After going back to 0.5.4, I found that there is still an error: I have sent an email to somebody with the option "autogenerate timestamp" active. So my sender address was "jms1218372255@..." The other person replied to "jms1218372255@...". Everything fine. Now I wanted to reply again, and virtual identity chose "jms@..." as the sender - and not ""jms1218372255@..." as I expcted. So I activated the option "open adialog to choose identity" "ask also if there is only one possible address". When I reply, I get a popup now and I can chose from exactly 1 possibility: "jms1218372255@..."!

comment:2 Changed 12 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

seems interesting and a little strange. Can you please check if there are some javascript errors? (Tools->Error Console) Seems like the process to replace the identity doesn't run completely.

Maybe there is an conflict with some other extension, it will be nice to see what extensions you have installed and if the problem occurs if they are deactivated. And, can you post the debug log (or send it by mail to just@…) because it will be interesting when the process stops working.

Thanks for the feedback, hope to solve the problem soon. Regards, Rene

comment:3 Changed 12 years ago by vi@…

2 other plugins installed, both are deactivated. Error console is empty. Debug output:

Thunderbird 3.0a1 (2008051420; Warp 4.5)

  • Allow Empty Subject {59f0fe53-cd29-49fe-8ae3-2ad2fa7f1c46} 0.3 [DISABLED]
  • Mail Redirect {CC3C233D-6668-41bc-AAEB-F3A1D1D594F5} 0.7.5 [DISABLED]
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.5.4

## v_identity: mod. FillIdentityList? ## v_identity: init. ## v_identity: adapt GenericSendMessage? ## v_identity: initSystemStage1. ## v_smtpSelector: selectUsedSMTPServer ## v_smtpSelector: setMenuToKey 'smtp11' ## v_smtpSelector: use SMTP from BaseIdentity?: smtp11 ## vI_msgIdentityClone: 'id18' ## initReplyToFields identity.replyTo: null ## vI_msgIdentityClone: no Reply-To row found ## v_identity: init done. ## vI_rdfDatasource read rdf from 'xxx\Profiles\default/virtualIdentity.rdf' ## v_identity: NotifyComposeFieldsReady? ## v_identity: initSystemStage2. ## vI_smartIdentity: msgComposeType = 6 ## vI_smartIdentity: Reply() ## vI_storage: getVIdentityFromAllRecipients() ## vI_storage: isMailingList ## vI_storage: isMailList false. ## vI_rdfDatasource: readVIdentityFromRDF. ## v_identity: getAddress: address name email ## vI_rdfDatasource: getRDFResourceForVIdentity: no Recipient given. ## vI_storage: found 0 address(es) ## vI_smartIdentity: SmartReply() ## vI_smartIdentity: ---------------------------------------------------------- ## vI_smartIdentity: reading header 'envelope-to' ## vI_smartIdentity: reading header 'x-original-to' ## vI_smartIdentity: found 'jms1218308920@xxx' ## vI_smartIdentity: reading header 'to' ## vI_smartIdentity: found 'jms1218308920@xxx' ## vI_smartIdentity: reading header 'cc' ## vI_smartIdentity: 2 address(es) after parsing, before filtering ## vI_smartIdentity: no filters configured ## identityCollection: add new address to result:jms1218308920@xxx ## vI_smartIdentity: filtering done, 1 address(es) left ## vI_smartIdentity: ---------------------------------------------------------- ## vI_smartIdentity: merged SmartReply? & Storage, 1 address(es) left ## vI_msgIdentityClone: addSeparatorToCloneMenu ## vI_msgIdentityClone: addIdentityToCloneMenu 'null' ## vI_storage: awSetInputAndPopupValue 'addressCol2#1' ## vI_storage: updateVIdentityFromStorage() ## vI_storage: isMailingList 'info@…' ## vI_storage: isMailList false. ## vI_rdfDatasource: readVIdentityFromRDF. ## v_identity: getAddress: address 'info@…' name email 'info@…' ## vI_rdfDatasource: getRDFResourceForVIdentity: recDescription=info@… ## vI_rdfDatasource: readVIdentityFromRDF no data found. ## v_identity: NotifyComposeBodyReady?

comment:4 Changed 12 years ago by rene

Summary: reply does not work in 0.5.5reply does not work in 0.5.5 for TB3a1

Hi,

there is definitely a problem with the extension, it stops working after
## vI_msgIdentityClone: addIdentityToCloneMenu 'null'
the following line should be
## initReplyToFields setIdentity ...
which is missing. I don't know how to debug this problem with the alpha version you are using, just try the same thing with version 0.5.5 and report the debug-log. Currently I'm trying to make the extension compatible with TB3a2, so you can also wait for the next (pre)release. Beside some smaller configuration problems, 0.5.5 should run fine on TB3a2pre (which is what I'm using for testing purposes regularly)

Regards, Rene

comment:5 Changed 12 years ago by anonymous

The funny thing is if I enable the popup asking me to select from the one and only possibility, it works fine.

comment:6 Changed 12 years ago by anonymous

Hi,

exactlay the same for me with TB 3.0.1 !

comment:7 Changed 12 years ago by rene

@anonymous:

can you please post the debug output and check the error-log (Tools->Error Console) for any messages?

Thanks, Rene

comment:8 Changed 11 years ago by rene

Resolution: fixed
Status: assignedclosed

please check if the problem still exists with current TB and reopen if required. Thanks, Rene

Note: See TracTickets for help on using tickets.