Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#80 closed defect (fixed)

VID Status bar lacks limitation of size and close button when many headers found, and should show only filtered headers // VID will sometimes treat permanently saved identity as virtual identity

Reported by: virtual-id-bugs@… Owned by: rene
Version: 0.5.5 Keywords:
Cc:

Description

Hello Rene,

as a newbie user of virtual-id (what a great thing to have, thanks!) I realized a few things with virtual-id (short: vid) that I think are buggy and/or might be immproved...

1) when searching to-headers is on, vid will sometimes treat a permanently saved identity like a virtual identity (but I can't reproduce this right now) I am having the smtp-display on, and at the time when the error occured I think it still showed "Standard" (which might better be labelled "smtp.displayname (Standard)"?).

2) with search to-headers for smart-reply ON, show status info on recognized headers ON, show status info time 0 (show always): if there are many to-headers, status info bar above the mail text of original message will expand without limit and use up all the screen so that I can't read the message below the status pane any more. Plus, I can't close vid's status bar as the close button is vertically centered on the status bar, and, with loads of to-headers found, will also disappear! (suggested fix: at least place the close button always at the upper right corner of status bar; limit horizontal size of status bar to a percentage of message pane horizontal size or to an absolute size (say 5 rows or so) and show scroll bar or [+] expander or just allow scrolling without scroll bar if there's more headers than fit into the limited status bar area.)

3) Question/Suggestion?: should status bar above original msg really show me ALL to-headers when I have an active filter set for smart-reply? I mean, vid will never use all those to-headers that are filtered out by my domain filter for smart reply. So why show them? Headers that will not be used by vid are of no interest to me in the vid status bar, since they will just use lots of screen space and they are simply a second copy of Thunderbird's real to-header-display of the original message which is right below vid's status bar. Suggestion (enhancement): On status bar above original messages, show only FILTERED headers if there is a filter set for smart reply.

Once again, thanks for your very useful add-on.

Regards

T.

Change History (3)

comment:1 Changed 11 years ago by rene

Owner: set to rene
Status: newassigned

Hi T.

thanks for your fruitful comments on the extension. To your points:

1) after some bug-reports I revisited the identity comparison and hope to have solved a lot of problems in upcoming 0.5.6. So hopefully at the time to release 0.5.6 those problems are history :). But if you are able to reproduce this behavior, please activate the debug output and post it (or send it to me by mail, it will contain some private information).

Your additional idea to show in the SMTP-Selector the name of the default smtp beside the default-tag (Standard) is nice, but won't work with the cooperation of other extensions like smtp-select. The decision which of your smtp servers is acting as the default smtp-server is not a virtual identity one, and it is only relevant (and finally true) in the moment of sending your mail, not before.

2) right, this might be a problem. working on it, let's see what's coming out :)

3) ok, might be a nice solution for 2, but I'm not completely glad about using the filter. Those filters might be really complex, depending on the way you are working with the feature. You can add a lot of regular expressions here, and working through them requires time. As you know, acquiring the headers is a process which happens on every change and selection in the 3-pane-Message-Window. The usage of the filters at this point might significantly slow down the usability of Thunderbird in slower machines, but I will test it and see whats going on.

Thanks for your nice input, great that you liked the feature which informs you about the headers. Nice regards,

Rene

comment:2 Changed 11 years ago by rene

Resolution: fixed
Status: assignedclosed

Hi T.

changed the notification in [350] and following. Now you can scroll, if the headers are requiring to much space. The idea with the filter seems not applicable, so you will see them all. But at least you can close the dialog now. You can find the new implementation in 0.5.6pre3 (see download section).

Nice regards, Rene

PS: closing the ticket by now, please reopen if you have any further comments especially on point 1) or any feedback on the solution.

comment:3 Changed 10 years ago by anonymous

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

Note: See TracTickets for help on using tickets.