Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#96 closed defect (fixed)

0.6pre causes weird cursor problems

Reported by: anonymous Owned by: rene
Version: 0.6.0pre Keywords: cursor compose
Cc: ffes@…

Description

With 0.6 pre installed, more often than not, I cannot use the arrow keys to move the cursor when composing an email - UNLESS/until I save it as a draft, then it works.

Also - it is really a 'bad thing' to offer an automatic upgrade to a 'pre' release version - suggest you not do that.

Going back to 0.5.6 solves the problem.

Change History (10)

comment:1 Changed 12 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

thanks for pointing to the surprising issue that so many people tested the new pre-release. The update-pointer of 0.5.6 pointed to the pre-versions. Stupid and bad fault, replacing a release with an alpha version. So repaired with [440] and released 0.5.7 with a new update-path. Sorry for the inconvenience.

Keep it open cause the cursor problem seems to be a real stopper for 0.6. Hard to find what causes this, was not able to reproduce it till now.

Regards, Rene

comment:2 Changed 12 years ago by ds-absorb.it@…

similar issue here:

  • i have paste/copy problems immediately after replying to an email.

The issue seems to be resolved if selecting another window and then going back to the original one.

comment:3 Changed 12 years ago by rene

Hi,

can you please report the Thunderbird/Seamonkey? Version you are using and the system (windows, linux, mac) on which it is running? Still trying to reproduce the problem.

Regards,

Rene

comment:4 Changed 12 years ago by ds-absorb.it@…

thunderbird version 2.0.0.17 (20080914) on XP for me

comment:5 Changed 12 years ago by ffes@…

Cc: ffes@… added

Experiencing this problem as well. Using TB 2.0.0.17 and Lightning 0.9 on WinXP.

comment:6 Changed 12 years ago by anonymous

I am so glad someone opened this ticket. I put up with the strange cursor problems for weeks before discovering that it was the Virtual Identity 0.6 alpha extension at fault. What a maddening problem it is, too.

comment:7 Changed 12 years ago by rene

right, still have no idea what the hell is going on. No easy way to debug this, so development of 0.6 is slowed down mainly because of this bug. If someone is able to give more information about the circumstances of the problem, post whatever might be helpful. Seems to occur only on windows - can somebody check it with TB 2.0.0.18 or TB 3.0b1pre? Wasn't still not able to reproduce the problem (no windows available)

Regards, Rene

comment:8 Changed 12 years ago by rene

reported to occur with TB 2.0.0.18 on winXP by Scott. Thanks

comment:9 Changed 12 years ago by rene

Resolution: fixed
Status: assignedclosed

yeah, finally I was able to reproduce the problem, and it's caused by an too early access to the window elements. Fixed with [460].

comment:10 Changed 12 years ago by anonymous

thanks a million

Note: See TracTickets for help on using tickets.