Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#99 closed defect (fixed)

Can't search from directory server when replying

Reported by: Onno Ekker <o.e.ekker@…> Owned by: rene
Version: 0.5.7 Keywords:
Cc:

Description

I have configured Thunderbird (through "Tools -> Options") to use address completion using both my local address books and our directory server. When I compose or forward a new mail, I get normal address completion from our directory server, with Virtual Identity enabled. When I reply to a message however, the address completion does not work. I see the following error message in my error console: Error: gAccountManager has no properties Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js Line: 2384

Change History (7)

comment:1 Changed 13 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

the Error message doesn't seem to be related to the Extension, MsgComposeCommands.js is part of a standard Thunderbird installation. Are you sure that the problem is related to virtual Identity (deactivate the extension and check)? Please update to 0.5.7 (which is available from the downloads section) and check again, this is the latest stable release (even if not yet published by addons.mozilla.org). Beside, please report which version of Thunderbird/Seamonkey? you are using.

Thanks for the report and nice regards,

Rene

comment:2 Changed 13 years ago by Onno Ekker <o.e.ekker@…>

Version: 0.5.50.5.7

I'm using Thunderbird version 2.0.0.17 (20080914) on Windows XP SP3, fully updated. With Virtual Identity 0.5.5 disabled address completion for replying works as expected, so the same as when composing or forwarding.

Since I do have a lot of other extensions I also tried it with a clean profile on my last weeks Shredder nightly and Virtual Identity 0.5.7. Here I get same result that for replying address completion with virtual identity enabled is broken.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080918034633 Shredder/3.0b1pre

Thanks for your great add-on by the way,

Onno

comment:3 Changed 13 years ago by Onno Ekker <o.e.ekker@…>

Resolution: fixed
Status: assignedclosed

This seems to be fixed with version 0.5.7 after all, both for Thunderbird 2.0.0.17 as for current Shredder Nightly (3.0b1pre 20081002). (On that version of Shredder the to-address list gets cleared when replying, but that's another bug in Shredder or in Virtual Identity...)

comment:4 Changed 13 years ago by rene

Hi,

not sure why but nice to hear that it works now :)

But, what do you mean with the "to-address list" which gets cleared? If you think it's a bug, it will be great if you come back and report with more details. There is sometimes a problem with replying if the 'intelligent' smart-reply mechanism selects a senders identity, still trying to fix it. This identity is automatically removed from the recipient list, maybe this is your problem?

Nice regards, Rene

comment:5 Changed 13 years ago by Onno Ekker <o.e.ekker@…>

I'm not sure what the other problem with empty to-address was. I upgraded to a later version of Shredder and I fiddled with the settings (switched both smart-draft and smart-reply off), but I think it already worked before that...

comment:6 Changed 13 years ago by Onno Ekker <o.e.ekker@…>

I'll experiment with it some more later on, and if I think it`s a problem, I'll file it here somewhere. I'd like to get ticket #100 :-)

comment:7 Changed 13 years ago by rene

okok, hope you will find a really good one for the #100. Never thought that so many reports might ever come in...

Rene

Note: See TracTickets for help on using tickets.