Opened 13 years ago

Closed 13 years ago

#239 closed defect (fixed)

Unable to send email after upgrade to VI 0.6.4

Reported by: martijn@… Owned by: rene
Version: 0.6.4 Keywords:



After the upgrade to VI 0.6.4 (on TB v2.0.0.23), I am unable to send email with VI enabled.

When I disable VI, sending mail does work correctly.

When VI is enabled, and the send button is clicked, nothting happens and the emails just stays open and isn't send. Even saving an email doesn't work any more.

What is wrong ?

With kind regards,

Martijn Janssen

Attachments (1)

VI_Errors.JPG (90.5 KB) - added by martijn@… 13 years ago.
Errors in TB Error Console after starting TB.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 13 years ago by rene

Owner: set to rene
Status: newassigned


please check the javascript error console (Tools Menu) for some problems related to virtual identity and post any errors. Have you tried to disable any other extension, maybe there is some conflict...

Hope to get this solved fast, nice regards, Rene

comment:2 Changed 13 years ago by martijn@…


There are several errors in the error console. I've attached a screengrab of the errors in the console.

These errors appeared right after I stared TB. I didn't even try to send a message.

I've disables several other extensions, but the problem really seems to be in VI. That is also the only one I've updated recently.

Hope you can help me track down the problem.

Changed 13 years ago by martijn@…

Attachment: VI_Errors.JPG added

Errors in TB Error Console after starting TB.

comment:3 Changed 13 years ago by rene


there seems to be a problem in your Storage File. Please move the virtualIdentity.rdf from your profiles directory to another safe backup-place (while Thunderbird is not running, check the error-log for the complete path). Than restart Thunderbird and see if the problem reoccurs, check the error-log for any messages.

Please report if this works for you, if you can accept the loss of formerly saved identities everything is ok now. Else, you can check the file and modify it in any editor to create valid xml in it, as far as this is possible and useful data is still available.

Nice regards, Rene

comment:4 Changed 13 years ago by martijn@…

Resolution: fixed
Status: assignedclosed


That did solve the problem.

The of RDF file, was about 54k large and contained nothing but NULL strings.

Very weird...

Thanks for helping me solve this.

Kind regards,


Note: See TracTickets for help on using tickets.