Opened 11 years ago

Closed 11 years ago

#264 closed defect (worksforme)

thunderbird crash when closing message view during reply send

Reported by: edA-qa@… Owned by: rene
Version: 0.6.6 Keywords: hang, crash, send, reply
Cc:

Description

The following, with the Virtual Identity add-on, always causes Thunderbird to hang.

  1. View a message in a tab
  2. Click reply
  3. Click send
  4. Immediately close the message tab (while it is still sending)
  5. Thunderbird hangs

I have isolated the Virtual Identity plugin as the most likely cause: with it turned off it doesn't happen, and with it as the only plugin enabled it still happens.

Virtual Identity 0.6.6 (also happened with 0.6.5) Thunderbird 3.0.4 Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100423 ""

I didn't have this problem in previous versions of thunder (2.x series). though honestly since the old reply windows covered the message view windows I was unlikely to have closed the message view while the reply was still visible.

Change History (4)

comment:1 Changed 11 years ago by rene

Owner: set to rene
Status: newassigned

Hi,

still was not able to reproduce this problem, not even to understand how this extension might have such an hard impact on Thunderbird. Can you reproduce this problem with Thunderbird 3.1 (and 0.6.6)?

Thanks for the report, nice regards, Rene

comment:2 Changed 11 years ago by anonymous

I can't easily install 3.1, the ubuntu repositories are now updated to 3.0.5 with the same effect.

Just to check again for myself, the error is reproducible here with all other add-ons disabled -- that is, with only Virtual Identity enabled. With it disabled the reply doesn't hang. I agree it seems odd, but I wonder if somehow the internals of Virtual Identity inadvertently reference the view window and not the reply window?

comment:3 Changed 11 years ago by anonymous

Version: 0.6.50.6.6

comment:4 Changed 11 years ago by rene

Resolution: worksforme
Status: assignedclosed

Hi,

still can't reproduce the problem. Please reopen the ticket if still relevant and you are able to reproduce the problem with TB 3.1+

Nice regards, Rene

Note: See TracTickets for help on using tickets.