Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#325 closed defect (fixed)

VI 0.8 does not work with Tbird 7 and 8

Reported by: nparks@… Owned by:
Version: 0.8.0 Keywords:
Cc:

Description (last modified by rene)

When using Earlybird 7.0a2 or Shredder 8.0a1 with VI 0.8.0 enabled, it is impossible to send any mail out. Any attempt to send produces no result.

Error Console saya:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://v_identity/content/vI_storage.js :: <TOP_LEVEL> :: line 329"  data: no]

When VI is disabled, messages can be sent.

Change History (5)

comment:1 Changed 10 years ago by anonymous

This ticket and #326 are the same. I left out a letter in the first sentence ("When sing" should be "When using"). In attempting to correct the misspelling I inadvertently created a duplicate ticket.

comment:2 Changed 10 years ago by rene

Description: modified (diff)
Resolution: fixed
Status: newclosed

Hi,

thanks for this report, there was some change in the interface. Fixed this with [d28e7866fa], will be part of to-be-released 0.8.1. You can use the snapshot from http://absorb.it/software/virtual_identity/other/virtual_identity-0.8.0-6-g88d97a2-tb+sm.xpi to check if this works for you.

Nice regards, Rene

comment:3 in reply to:  2 Changed 10 years ago by anonymous

Replying to rene:

Still does not work with 7.0a2:

Error: An error occurred executing the cmd_sendButton command: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAbDirectory.childCards]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://v_identity/content/vI_storage.js :: <TOP_LEVEL> :: line 338" data: no] Source File: chrome://global/content/globalOverlay.js Line: 100

comment:4 Changed 10 years ago by rene

Hi,

not able to reproduce this (with 7a2 and 8a1 from 20thJuli) and even not able to find the issue in the docs, but think there is a workaround. Just implemented another check in [0a199faa097bbd7] and uploaded a test-version at http://absorb.it/software/virtual_identity/other/virtual_identity-0.8.0-7-g0a199fa-tb+sm.xpi

Interested to hear your feedback, nice regards, Rene

comment:5 in reply to:  4 Changed 10 years ago by anonymous

Note: See TracTickets for help on using tickets.