Opened 15 years ago

Closed 15 years ago

Last modified 12 years ago

#43 closed defect (fixed)

Upgrade to v0.5.0 sticks at upgrade step 2/2

Reported by: virtual-id at theartofmusic dot co dot uk Owned by: rene
Version: 0.5.0 Keywords:


Hi Rene

Thanks for a great extension.

However, when upgrading from 0.4.4 (I think it was!) the Extension Upgrade/Installation? is sticking at upgrade step 2/2, saying

"## vI_rdfDatasource read rdf from 'C:\Documents and Settings\AWarwick\Application Data\Thunderbird\Profiles\jze2apgs.default/virtualIdentity.rdf' starting upgrade.

checking for previous version, found null extension-upgrade required. transferring VirtualIdentity? information from AddressBook? to RDF file, this might take a while:"

I've tried this several times, including uninstalling the Add-on and deleting the virtualIdentity.rdf and virtualFolders.dat files from my Thunderbird Profile.

Any ideas why it might be doing this?

(I'm also not able to find how to re-use a Virtual Identity after it's successfully been used.)

I'm running TB version (20080213) on WinXP SP2 Dell Inspiron 9300 2Gb.

(In Ticket Properties below, I've selected 0.5.0pre4, but it should really be 0.5.0)


Change History (4)

comment:1 Changed 15 years ago by rene

Owner: set to rene
Status: newassigned
Version: 0.5.0pre40.5.0


can you please have a look at the Javascript Error Console (in the Tools Menu) and post any errors? You can reach the console if you close the upgrade-dialog after it stops (just wait a while before closing it). Is the processor usage unusually high fo the time you have to wait?

regards, Rene

comment:2 Changed 15 years ago by rene

  1. The Task Manager reported no usage for Thunderbird; most of the processor "usage" was System Idle.
  1. After exiting the upgrade window (which appears every time I start up Thunderbird), the error console reported
  • Error: [Exception... "Component returned failure code: 0x80004003

(NS_ERROR_INVALID_POINTER) [nsIRDFService.GetLiteral?]" nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)" location: "JS frame :: chrome://v_identity/content/vI_rdfDatasource.js :: anonymous :: line 169" data: no] Source File: chrome://v_identity/content/vI_rdfDatasource.js Line: 169

comment:3 Changed 15 years ago by rene

Resolution: fixed
Status: assignedclosed

solved with [163]

comment:4 Changed 12 years ago by anonymous

Note: See TracTickets for help on using tickets.