Opened 15 years ago

Closed 15 years ago

Last modified 12 years ago

#5 closed defect (fixed)

email doesn’t send

Reported by: Avatar-X Owned by:
Version: Keywords:


I’m having a real problem with Virtual Identity. I’ve upgraded to a new computer and copied over my settings, and I can’t figure out why this is happening.

Whenever I try to send an email with VID, the email doesn’t send. It worked fine on my old machine.

Here’s what happens when I click send:

  • A new account named “virtual Id0″ appears in the background account list
  • Nothing else happens.

Here’s the contents of the debug window. (The last line is where it stops)

Thunderbird (2007060411; Windows NT 5.1)

  • ImportExportTools? (Mboximport enhanced) {3ed8cc52-86fc-4613-9026-c1ef969da4c3} 1.2
  • Signature Switch {2ab1b709-ba03-4361-abf9-c50b964ff75d} 1.4.4
  • Talkback talkback@…
  • Virtual Identity {dddd428e-5ac8-4a81-9f78-276c734f75b8} 0.4.3pre

——————————————————————————– ## v_identity: replace MsgComposeCloseWindow? ## v_identity: adapt GenericSendMessage? ## v_identity: NotifyComposeFieldsReady? ## vI_smartIdentity: msgComposeType = 0 ## vI_smartIdentity: cant get URI of former Message ## v_identity: NotifyComposeBodyReady? ## v_identity: replace GenericSendMessage? (Virtual Identity activated) ## v_identity: VIdentity_GenericSendMessage ## vI_account: Stored virtualIdentity (name Avatar-X email testemail@… smtp smtp2) ## vI_account: Stored (doFcc true fccFolder mailbox:// fccFolderPickerMode 1)

Change History (4)

comment:1 Changed 15 years ago by Avatar-X

Oh, to add to the above: The error is listed as follows in the Error Console:

Error: [Exception… “Component returned failure code: 0×80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.Delete]” nsresult: “0×80004005 (NS_ERROR_FAILURE)” location: “JS frame :: chrome://v_identity/content/vI_account.js :: anonymous :: line 135″ data: no] Source File: chrome://v_identity/content/vI_account.js Line: 135

comment:2 Changed 15 years ago by Avatar-X


I managed to fix the bug by editing vI_account.js and removing the two lines


on line 100 and on line 135. I’m not sure what these two lines do, but that’s where it was choking, and I removed them and now it works.


comment:3 Changed 15 years ago by rene

Resolution: fixed
Status: newclosed

thanks, workaround in [13]

Note: See TracTickets for help on using tickets.